2

How can I prevent WordPress from converting links in my page content into hyperlinks?

For example if I write http://www.test.com I don't want it converted to a link.

1
  • Please specify the version of wordpress you are using.
    – hakre
    Aug 26, 2010 at 9:27

2 Answers 2

1

WordPress does not automatically convert URLs to hyperlinks.

2
  • It must be some plugin I have then :S I will have to track it down Aug 26, 2010 at 2:33
  • 2
    Today is 2015, and it does now.
    – Ooker
    Sep 7, 2015 at 7:59
2

It's the Editor TinyMCE's embed plugin to disable it you will also need to disable all other embeds (twitter, images, youtube, etc)

If you still want to proceed, then enter this code in your theme's functions.php

function disable_embeds_code_init() {
wp_deregister_script('wp-embed');
 add_filter( 'tiny_mce_plugins', 'disable_embeds_tiny_mce_plugin' );
}
add_action( 'init', 'disable_embeds_code_init', 11 );

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.