0

I'm encountering some trouble moving a Wordpress installation from a development to a production server. The development server works just fine, but when moving to production the blog page suddenly stops working.

Homepage: http://www.elireview.com Blog: http://www.elireview.com/blog/

The homepage and the sub-pages of the site work fine, but when in Settings > Reading I set posts to display on the homepage, it them stops working and /blog/ works like expected.

The page produces absolutely no HTML or error messages, and nothing is recorded to the server logs, so I am working blind here. I've tried just about every recommendation for "blank page" on the web, but I can't find any solution that works.

Any assistance is greatly appreciated.

4
  • How do you mean, you set posts to display on the homepage? Shouldn't they be displaying at /blog/?
    – vancoder
    Mar 18, 2013 at 23:58
  • When I use the settings in Settings > Reader to specify where I want the blog to display - it can be set to either the homepage or to a static page. No matter where I set it, the page that is supposed to show the blog is completely blank/empty.
    – mcleodm3
    Mar 19, 2013 at 0:01
  • What is on line 24 of /wp-content/themes/eli-marketing/header.php. Courtesy of : elireview.com/blog/blah
    – s_ha_dum
    Mar 19, 2013 at 3:47
  • Line 24 is a conditional statement: <?php if(is_page('2245') || $post->post_parent == '2245'): ?> It's meant to take action if the header is rendering for a specific page or the children of a specific page. Not sure why it's throwing that error, but removing it does not fix the problem on the blog.
    – mcleodm3
    Mar 19, 2013 at 10:31

1 Answer 1

0

Make sure to read over this thread. There are step-by-step instructions on dealing with sub-folders and root URLs. It's not as simple as changing the settings in WP, you have to edit a couple files to make it work as well.

http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

1
  • Thanks for the pointer, but that's not the problem. WP is installed in the root - it's just that I want the blog to display on a page, not on the homepage.
    – mcleodm3
    Mar 19, 2013 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.