0

i read alot of atricles taking about this but i could fix my problem yet .. i want to make the permlink custom

/%category%/%postname%

and i searched for the .htaccess in the wordpress files and i couldn't find it so i created one and added this code

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /sitename/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /sitename/index.php [L]
</IfModule>
# END WordPress

in the RewriteBase this name is the name of the folder of wordpress in my hosting , when i open my site the permlink changed as i want but when i open the page it gives me an error 404 Not Found error by the way i tried to choose the twentytwelve but its not working also , i added the .haccess file in the file mythemes in mytemplate is that the right place ??

0

If your Wordpress installation is in the folder 'sitename', than this .htaccess should go in that folder. Not your theme folder.

From the Wordpress codex: WordPress's index.php and .htaccess files should be together in the directory indicated by the Site address (URL) setting on your General Options page (http://codex.wordpress.org/Using_Permalinks)

  • you mean directly in the folder not inside any othe folder ?? – sarah Mar 10 '13 at 8:25
  • its working thaaaaaanks alot Vivienne :) – sarah Mar 10 '13 at 8:26
  • You're very welcome. You might want to accept my answer, so that this issue shows up as resolved (Accepting Answers: How does it work?) – Vivienne Mar 10 '13 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.