2

I'm able to log into the website but the moment after login, I get a white screen in wp-admin. I can still access the website and it shows that I am logged in with the toolbar at the top of each page but whenever I venture off into wp-admin, I'm met with a white screen.

I've tried renaming the themes and plugins folder, even deleting both. I'm tried increasing the php memory limit to 128M but still no luck.

Any advice? If I do have to reinstall Wordpress, how would I not lose everything that is already there?

EDIT: I've also turned on debug but still do not get any errors, warnings or notices.

  • can you see the URL redirect link when wordpress is uploading ? – krembo99 Mar 7 '13 at 4:48
  • One for the manual update. It helped my blank wp-admin page. codex.wordpress.org/Updating_WordPress – user72728 May 6 '15 at 20:07
3

As a rule of thumb, always remove the ending ?> of your .php files, especially if it's a functions or config file that gets parsed before headers are sent to the page. If after that ?> you accidentally add a space, a tab character or a new line, there's your invisible error.

2

You should enable WP_DEBUG and WP_DEBUG_LOG.

in wp-config.php find:

define('WP_DEBUG', false);

And replace it with:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);

Run your wp-admin and check inline errors and error.log in wp-content folder.

  • that's right, in order to fix the issue someone have to enable debug mode to explore more what the issue is and fix it. – sdx11 Jul 29 '17 at 18:21
1

It may be an issue because there is a space at the end of wp-config.php file or function.php file.

for more info see in http://creativedev.in/2012/02/blank-screen-of-wordpress-admin-panel/

1

To all the folks who get this kind of error a must check option. turn on error reporting if you have commented the lines in your wp-config.php

@ini_set('display_errors','Off');

and than check for error. if it has the error like this

PHP Warning: Cannot modify header information - headers already sent by (output started at /[server info]/wp-config.php:77)

than check your wp-config.php for extra space at top and bottom of the page.remove extra line spaces even. and than re-upload the wp-config.php.

If you get other file than wp-config.php than remove blank space in that page.

Most of time this will solve your problem.

Happy Coding!!!!

0

It could be a whitespace problem in your functions.php file. Check for any empty newlines before or after the php tags at the beginning and the end of the file.

If you're sure it's not a plugin or theme causing this (i.e. you've tried the Twenty Eleven default theme and renamed/deleted all plugins), then you could also try re-uploading all your Wordpress core files.

Do this by downloading the latest stable version of Wordpress as a ZIP file, then replacing all the files and folders in your Wordpress directory, except the wp-content folder.

When loading your site after this, you'll be prompted to enter your database credentials for the wp-config file as if you were installing Wordpress for the first time. This is just to populate the wp-config file so your data can be accessed. The site should work again on the frontend like it did before. Now try logging into /wp-admin and see if the admin panel works.

0

Check with these options:

-> Disable ALL plugins by resetting the plugin folder BY FTP. -> Change your theme to default to rules out theme level problem. -> Remove all unwanted code from htaccess -> Upgrade your Wordpress manually to the latest version

0

You need to enable WP_DEBUG and then diagnose your website. Here is nice article about it 4 ways how to fix white screen of death in wordpress

0

Errors like this are logged. Check the error log on your server. On the off chance that you can't discover the log, it would be ideal if you contact your host.

Interim, just to check enable WP_DEBUG and WP_DEBUG_LOG and after an error, take a look at wp-content/debug.log to check whether anything gets logged there.

Past this in your wp-config.php file:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG', false );

Then check the debug.log file which is in wp-content/debug.log.

0

I ran into this exact problem after upgrading my server.

So I just rolled my PHP version back from 7.2.14 to 7.0.33 and that seemed to fix the issues for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.