0

My blog has been working fine for months. Today when I tried to open it I got the following errors:

Warning: require(/home/dhabitat/public_html/blog/wp-includes/functions.php) [function.require]: failed to open stream: Permission denied in /home/dhabitat/public_html/blog/wp-settings.php on line 69
Fatal error: require() [function.require]: Failed opening required '/home/dhabitat/public_html/blog/wp-includes/functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dhabitat/public_html/blog/wp-settings.php on line 69

Does anybody know how it can be fixed. thanks

1
  • 2
    I think , you should set appropriate read permissions on wordpress files and folders. – Vinod Dalvi Mar 5 '13 at 9:01
0

Check the permissions of the functions.php.

This page in de Codex about changing file permissions explains a lot about wich permissions you have, or can use.

On computer filesystems, different files and directories have permissions that specify who and what can read, write, modify and access them. This is important because WordPress may need access to write to files in your wp-content directory to enable certain functions.

2
  • thanks mike . i have changed function.php permissions 000 to 644 and problem solved. – user20890 Mar 5 '13 at 10:51
  • Glad your problem could be solved so soon. Could you hit the check at the left side of the answer to solve it? – Mike Madern Mar 5 '13 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.