2

I have Wordpress 3.5.1 and I use Bluehost hosting service. When I schedule posts after that time passed, WP posts dashboard shows "Missed schedule" message under the date. Then I checked my wp-config.php has define('DISABLE_WP_CRON', true); there's no such a define line. Then I added define('DISABLE_WP_CRON', false); under the database lines. After that I added following code to my .htaccess file.

<Files "wp-cron.php">
Allow from All
Satisfy Any
</Files>

But still this issue not fixed. What is the reason? Is it my hosting company issue or my WP issue? How do i fix it?

  • Enable debugging and set it to write to a log file. Post related debugging data. – s_ha_dum Feb 23 '13 at 15:14
  • I haven't noticed a problem on Bluehost in the past, but could be good to bring it up with them. I would be curious to know where that DISABLE_WP_CRON line came from. – Jake Feb 23 '13 at 15:25
1

You don't need that line in wp-config.php as wp-cron is enabled by default.

If you install the Cron View plugin you are able to see when the different jobs are scheduled. You can then trigger wp-cron manually by going to this URL with your browser:

http://your-domain.com/wp-cron.php?doing_wp_cron

If after this the actions you expected where successfully performed. You really have a problem with your hosting provider. Maybe he has cURL/fsockopen disabled or the DNS is not properly configured so he can't resolve an IP for your domain. In that case you would need to contact tech-support.

  • S1Lv3r, I have installed "Cron View" plug-in, it shows some of my plug-in schedule tasks. If i go to this URL your-domain.com/wp-cron.php?doing_wp_cron It shows website offline mode (I use CloudFlare). – Chathu Feb 24 '13 at 3:01
  • Updated! After I have disabled W3 Total Cache no issue. Looks like it's W3 Total cache issue. Thanks all of you guys your support. :D – Chathu Feb 24 '13 at 5:56
  • Chathu, did you manage to fix the problem with W3 Total Cache or you just stopped using it? I got the same issue with the plugin, but I don't want to deactivate it as I need it... – vlood May 14 '13 at 12:27
  • If you're using Page Caching, make sure wp-cron.php is one of the pages that is never cached in the cache settings. – Otto Oct 13 '13 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.