0

Is there a way to mark a plugin as "never upgrade this plugin" ?

I can't upgrade my OpenID plugin, and this prevents me from clicking the otherwise convenient "Upgrade All Plugins" button.

3

Hi @ripper234:

Either 1.) edit the plugin header comment in the main plugin file and change the Version: value to something like 999, or 2.) move the plugin to the "Must Use" plugin directory: /wp-content/mu-plugins.

Here's an example from /wp-content/plugins/akismet/akismet.php of the plugin header comment for Akismet:

/*
Plugin Name: Akismet
Plugin URI: http://akismet.com/
Description: Used by millions, Akismet is.....
Version: 2.5.2
Author: Automattic
Author URI: http://automattic.com/wordpress-plugins/
License: GPLv2
*/

Here's a blog post that explains the "Must Use" plugins (albeit I don't understand why he chose the title he chose):

  • Finally got around to testing this, works like a charm. – ripper234 Jun 7 '11 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.