I'm getting an "file.png exceeds the maximum upload size for this site" error. It's saying the upload limit is 1MB when trying to upload an image that is 2.5M on WP 3.5. It is setup in multi-blog mode (if that matters).

I have set my php.ini file to 64M for post_max_size and upload_max_size, and it's working for other (non WordPress) sites on my server. I have no idea where the 1MB limit is coming from. I don't have a host, we run out own servers. Any ideas?

From phpinfo(); :

upload_max_filesize     64M     64M
post_max_size           65M     65M
up vote 8 down vote accepted

It is setup in multi-blog mode (if that matters)

That will matter a lot. you probably need to ask the super admin to change the upload setting for your site https://codex.wordpress.org/Network_Admin_Settings_Screen#Upload_Settings

  • OK, I found the maximum upload size in "Network Settings" and changed it to "9999999 KB" But I'm still getting the error. Is there a another place I should check? – Nick Jan 25 '13 at 13:13
  • OK, it now appears to be working. I didn't do anything else, just waited for a bit. WordPress seems to do that sometimes where settings don't work until you wait a while? Maybe they're cached or something. Anyway, your answer worked. – Nick Jan 25 '13 at 13:27

this may help - add in .htacess

<IfModule mod_php5.c>
php_value post_max_size           80M
php_value upload_max_filesize     80M
</IfModule>
  • 1
    Two of those values are lower than values already set. – s_ha_dum Apr 26 '13 at 15:20

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.