I found out I was editing themes wrong, and that I should be using child themes, so I duplicated the theme I was using, and told it to inherit off of its parent. That's about the only thing I did, I was planning on going through and finding the code I didn't touch and removing those files, but I didn't get that far.

After trying to enable my new child theme, every single page, including admin pages gave 500 errors. there is nothing in my log file. I've tried renaming the folder containing the parent theme to the child theme, in hopes that WordPress will load that, and not generate the errors anymore, but it didn't work. I've tried changing the content of style.css in the child theme to be the same as the parent theme, but that didn't work. I don't know what to do.

Snippet from the child theme's style.css

Theme Name: pitch-child
Author: me
Version: 1.0
License: GPL 3.0
License URI: http://www.gnu.org/copyleft/gpl.html
Description: Pitch is a simple, minimal business and portfolio theme. It uses custom post types to make it easy to add your content. Pitch also features a big bold slider to put your work front and center.
Tags: gray, two-columns, fixed-width, custom-background, custom-menu, featured-images, theme-options, threaded-comments, translation-ready

Ubuntu 12.10, Apache, Mysql,Wordpress

also, nothing showing up in the console on the page that shows the 500 error. usually there is some sore of message about the 500 error there.

the host hasn't completely stopped working. I was able to access an image. I think it has something to do with a dependent library all pages are using, that can't get accessed.

  • 500 is a fairly broad error, but the clue will be in the web server error log - is this apache, if so do you have access to the logs?
    – Paul
    Jan 22, 2013 at 4:57
  • yes, this is apache, and nothing is showing up in the error logs. the error logs work, every time I restart the server, it shows a little message about that.
    – QxQ
    Jan 22, 2013 at 4:58
  • 2
    Your style.css is missing the Template reference to the parent theme directory (see Codex). Whether this is causing the 500 errors I don't know, but your child theme certainly won't work without it.
    – Milo
    Jan 22, 2013 at 5:24
  • See Debugging in WordPress, and set WP_DEBUG and WP_DEBUG_LOG so that you can get the actual errors written to wp-content/debug.log and get some idea about what is causing your 500 error.
    – webaware
    Jan 22, 2013 at 9:08
  • I had Template, I took it out to try and make it a parent theme again, since the only thing different was those lines, that didn't work. I forgot to put it back in when I posted it.
    – QxQ
    Jan 22, 2013 at 15:31

2 Answers 2


You have a PHP error in your child theme which is causing that. If you don't see an error in the apache log, it might be that you PHP errors are stored at some other location, or just not being reported at all. Check your PHP error settings in your php.ini file.

Anyway, most likely your problem is caused by the code in your child theme's functions.php file. If you just copied it from the parent theme you have a problem with redeclaration of function. Try to rename it and see if you don't get the 500 error anymore.

If you did copy the functions.php file then you are the doing it wrong as the parent theme's functions.php file is being loaded as well,m therefor the functions in it are going to be executed and available to be called from your code


Try renaming the wp-content/themes directory to something like themestemp. Your front-end will be blank, but you should have access to your admin. If you still don't have access, then it's not a problem relating to your theme; more likely a WordPress core problem or (unlikely) a webhost problem.

If the above doesn't work, try renaming your .htaccess to something else temporarily.

  • this is a nice solution to be able to access the wp-admin pages. it doesn't really help me specifically since I was trying to recover the theme, but it worked.
    – QxQ
    Jan 22, 2013 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.