I have configured a VPS running CentOS 6.3 and Plesk 11. The install of a blank version of Wordpress works well. However, I have problems with updating Wordpress and searching for plugins. The two problems:

  • When trying to search a new plugin from within the Wordpress backend I get an 'Unknown error'. I have found a lot of references with people having this problem, however it is usually solved by the webhost as this is a server configuration issue. Since I am now my own webhost with the VPS, I would like to know how to solve this myself and improve my server configuration. I did not find anywhere online how to do this in practice.

  • A (most likely) related problem is that Wordpress does not show any new updates. The current version of my blank install is 3.4.2 but once logging in, Wordpress does not indicate that I should update to version 3.5. Also after performing an update check, Wordpress does not find the new version.

Updating everything manually (via FTP) works well of course. But I would like the update process from within wordpress to work.

Anyone any ideas how to improve my PHP or other configurations to solve these update problems? Any help appreciated!

  • 1
    Chances are this is not a WordPress issue. I'd guess that either CentOS has a bad network configuration and can't connect to the outside, or PHP has some of its functions disabled and can't query remote servers. It would probably be better posted on Server Fault
    – s_ha_dum
    Commented Dec 22, 2012 at 15:24

2 Answers 2


WordPress makes network requests via HTTP API abstraction layer, that tries to pick optimal method to connect - depending on server configuration (curl being one of preferable and common).

In your case it seems either network connectivity fails completely or WordPress fails to select working transport to make network requests.

You can use Core Control plugin to see what network transports are available/selected as detected by WordPress.

  • Thanks a lot, that is a great plugin for getting insight in my server configuration. It seems that cURL (although it is installed) does not have the right permissions. When testing the connection, it says: An Error has occured: Failed to connect to 2402:9400:1000:2::8e: Permission denied. What ports or what addresses should I open to get the Wordpress HTTP API to work? Thanks a lot! Commented Dec 22, 2012 at 20:20
  • @Jasper Buijnsters no remote idea, ask your hosting support (if you have any). It seems it's curl that fails, not WP.
    – Rarst
    Commented Dec 22, 2012 at 20:43

PHP is probably compiled without curl support. While we're at it, it's probably also compiled without some other useful libraries like GD. This should cover the basics for you:

sudo yum install php-common php-gd php-mbstring php-mcrypt php-devel php-xml php-curl

php-curl is probably unnecessary because it should be included in php-common, but I added it just in case

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.