Can you help me figure out why my RSS feeds do not work? I have a very standard Wordpress 3.4.2 install for this Solar Blog, however none of the RSS, RSS2, or Atom feeds will function. I am using permalinks in the following format:

http://blog.paramountsolar.com/2012/12/18/sample-post/ (day and name, option #2)

This appears to break the rss feed. If I set the Permalinks to 'ugly' mode it works as expected... with any other setting it fails:

For example:


Kicks out this error:

This XML file does not appear to have any style information associated with it.

The document tree is shown below.

<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:wfw="http://wellformedweb.org/CommentAPI/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:sy="http://purl.org/rss/1.0/modules/syndication/" xmlns:slash="http://purl.org/rss/1.0/modules/slash/" version="2.0">
<title>Paramount Solar Blog » Page not found</title>
<atom:link href="http://blog.paramountsolar.com/feed/rss2" rel="self" type="application/rss+xml"/>
We discuss everything about Solar Power, Solar Panels and Solar Energy!
<lastBuildDate>Tue, 18 Dec 2012 10:37:20 +0000</lastBuildDate>

closed as too localized by Chris_O, brasofilo, Rarst Dec 22 '12 at 23:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Disable all plugins and switch to TwentyEleven. Does it still happen? – fuxia Dec 18 '12 at 21:44
  • Affirmative. I broke it down to the most basic, and for some reason the only thing that will allow the rss feed to be seen normally is IF I remove the custom permalinks and then use the format: blog.paramountsolar.com/?feed=rss2 – Nathan Pizzo Dec 18 '12 at 21:53
  • Besides just the obvious SEO value of using nice looking permalinks... the posts are many, and the links will be broken if I don't use the day and name option.... for permalinks. – Nathan Pizzo Dec 18 '12 at 21:55
  • are ALL permalink setups doing this? Do you have any custom post types and taxonomies? If so what are their slugs? Do you happen to have any posts or pages also called 'feed'? Aggregation plugins? Do you set up any custom rewrite rules? Have you tried upgrading to v3.5? – Tom J Nowell Dec 19 '12 at 12:16

Switch to defaults, plugins and themes. Use the flowchart to find your problem; most it is a custom error from a plugin or theme.

enter image description here

  • I am way ahead of you... I setup a SEPARATE install of this blog on a dev area... onedaysolarblog.com This is identical in every way except it has the 'OLD' logo so you'll know it's the dev site (blue 'SOLAR' logo is old) If you want temp access to this - I can get you a login to see what might be going on. I have tried to turn everything off (plugins) and change to twenty-ten theme. Nothing seems to work except the UGLY style permalinks (none). – Nathan Pizzo Dec 18 '12 at 21:58
  • As I mentioned.. setting the permalinks to ugly mode (none or default) allows this link to work: onedaysolarblog.com/?feed=rss2 – Nathan Pizzo Dec 18 '12 at 22:02
  • I am not apposed to using another theme (even customizing the default 2011 theme) and see if that works. I suspect it is either: the theme (voltage) or the host (hostGator) that is causing the issue. It seems very odd, since rss should be a very basic function built into Wordpress. I am not running 3.5 but I can even try running that on the dev site and see if that helps. At this point I just want to get it working and preserve the posts, images and basic look and feel. BTW... I have set the permalinks to UGLY for this dev site. – Nathan Pizzo Dec 18 '12 at 22:19
  • Looks to be the theme afterall... I am going to try to fully customize the default theme to match my previous look and feel using only CSS, and styling and see how it works. //fingers=crossed. – Nathan Pizzo Dec 18 '12 at 22:35
  • Yes, you can use your theme and plugins. But you must find the plugin, theme, which send the error to your feed and after this you can fix the error. It is your theme the problem; maybe the plugin Theme Check help you to find the problem easier. Also is the plugin Deprecad Functiond and Debug Object good helper. – bueltge Dec 18 '12 at 22:47

This (the document tree) is the default behaviour for some browsers, such as Google Chrome and Opera. They are reading the feed as an XML file, and displaying it accordingly.

Other browsers, such as Mozilla Firefox, will display a preview of the feed. If you need to see a preview of the feed content in Google Chrome, check out the RSS Subscription extension.

Not the answer you're looking for? Browse other questions tagged or ask your own question.