We purchased an SSL certificat from network solutions (would never recommend them to my worst enemy, btw).

Apparently it's activated... did a few checks that says it's activated for our domain. But when I put in https://www.texasshredderclassic.com the entire site breaks. To be more specific, by "breaks," I mean it completely disables the CSS, and my login User+Password no longer work (seems like this might be a clue?)

I've tried downloading Wordpress HTTPS, but that kicks me out of the admin page and also mangles the CSS.

I don't care if it works on the entire site, just need it working for our form page (texasshredderclassic.com/registration) – using gravity forms and connecting to authorize.net!

I'm tearing my hair out here because I don't have a clue where to go next. Seems like we have the SSL cert... just can't get the damn thing to work! Any help is GREATLY appreciated!

  • '...the entire site breaks' isn't really helpful to anyone who'd be willing to offer assistance. Can you edit your question to detail the problems and behaviors you're seeing?
    – Steve
    Commented Dec 12, 2012 at 22:31
  • thanks for the suggestion, added more detail, hopefully this helps! Thanks! Commented Dec 12, 2012 at 22:36
  • I can't find any issue with CSS, loads fine for me even on the registration page. No errors in Firebug or certificate/SSL warnings. Until I get to the registration page; where the form tells me the page isn't secure.
    – Steve
    Commented Dec 12, 2012 at 22:46
  • that's with https:// in front, Stephen? Commented Dec 12, 2012 at 22:48
  • Yeah, how else would I test the certificate? ;)
    – Steve
    Commented Dec 12, 2012 at 22:49

4 Answers 4


For the login part, this works for me ...

Paste the following line in your wp-config.php

if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https') $_SERVER['HTTPS']='on';

but make sure that you do it before the following line

require_once(ABSPATH . 'wp-settings.php');

By doing so you can get your admin panel back ... See details here

Also to avoid getting Mixed content, after restoring your admin panel, remember to go to SETTINGS, General, change Server URL from http to https.

  • 3
    goodness grief. after looking at about a dozen stupid ssl articles on google that never mention this - this works.
    – Dobler
    Commented Apr 13, 2017 at 0:25
  • this should be accepted answer, works great! Commented Aug 20, 2017 at 19:11
  • 1
    the widest framework used on the web, and after years it still needs fixes like that. Horrible architecture that doesn't allow to make it stable Commented Jul 22, 2018 at 21:55
  • is this still up-to-date? I solved it by installing two plugins: - wordpress.org/plugins/really-simple-ssl and - wordpress.org/plugins/remove-http
    – rubo77
    Commented Aug 28, 2018 at 10:44
  • Thanks, this worked. no need for extra plugins. I added the info to the issue at core.trac.wordpress.org/ticket/38273#comment:5
    – rubo77
    Commented Oct 27, 2018 at 19:28

Go to your WordPress General Settings and change the WordPress Address (URL) and the Site Address (URL) from HTTP to HTTPS.

ps. And disable all the plugin breaking your site.

If that doesn't fix this there is a proper guide here and several steps you can take: https://managewp.com/wordpress-ssl-settings-and-how-to-resolve-mixed-content-warnings

  • I'm worried about doing this because I had a friend who tried to do this with SSL and it broke his wordpress entirely (when he moved it to https://) And also, won't this make it so all my pages load with https in front, making it much slower? Commented Dec 12, 2012 at 23:20
  • should not break anything. just did that last night.
    – Sagive
    Commented Dec 13, 2012 at 1:31
  • It depends on your theme/plugin code, if it is properly written it won't effect anything.
    – Wyck
    Commented Dec 13, 2012 at 1:40
  • Alright, I did it... now it's https://, but the certificate still says insecure? God I am way over my head... Commented Dec 13, 2012 at 3:56
  • Worked for me!!
    – Abram
    Commented Feb 27, 2015 at 15:05

This type of CSS "breaking" is caused mostly due to accessing files via HTTP request on an HTTPS connection, or to be short, accessing insecure files.

In the provided link, the Registration form is loaded in an iframe, and also, its CSS files are loaded by HTTP and not by HTTPS connection.

So, if you have direct access to the files that is served as registration form, changing all http:// to https:// might does the job, but I've been using the SSL Insecure Content Fixer, and it works fine till now.


Have you tried running SSL Insecure Content Fixer? (disclosure: I wrote it, but I just want to know have you tried fixing your problem with this plugin). It should clear up most of the script load errors, at least for plugins that haven't been too naughty.

I notice that you're running WP 3.5. I had a report this morning that someone running WP 3.5 with stylesheets loaded using bloginfo('stylesheet_url'); was getting the same problem, insecure content report on their theme's stylesheets. Can you look at your theme and tell us how your stylesheets are loaded?

  • Where do I find this info at? Tried using SSL Insecure Content Fixer... no difference! Commented Dec 12, 2012 at 23:49
  • Look in your theme's header.php, find the <link rel="stylesheet" bits and tells us what they say.
    – webaware
    Commented Dec 12, 2012 at 23:53
  • @user1727053: did you look in header.php in your theme? What are the stylesheet links? Are you still running SSL Insecure Content Fixer or WordPress HTTPS? (if so, then you have some bad plugins / theme; if not, please turn one of them on so that we can see what's left that is broken!)
    – webaware
    Commented Dec 13, 2012 at 8:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.