So I ran into an incredibly odd and frustrating problem today. As the title says, as of today one of the posts on the website is going to a 404 page.

This is the ONLY post that goes to a 404 page. The post exists, I mean, I can edit it in the backend and it obviously appears throughout the website (like on a homepage slider and a list of posts). The permalink just won't go. If I change the permalink structure to default, it works fine, but like any civilized person I want to use the 'postname' structure.

I've tried deleting the .htaccess and reuploading it. I've tried deleting it and allowing Wordpress to make a new one upon saving the permalink settings. I've tried various permissions on it. Nothing works and I'm starting to think it's not an htaccess problem... anyone have any ideas?

  • I ran into the same thing a while back. I never got a true fix, but I ended up changing the page slug (or deleting the page and creating a completely new page, I don't remember which), then adding a 301 redirect to the .htaccess from the previous URL to the new URL. - I would also like to find the real reason and fix to this situation. – Travis Pflanz Dec 7 '12 at 22:09
  • Are you using the Redirection plugin? – shea Dec 7 '12 at 22:10
  • @bungeshea, are you suggesting that is the cause of the problem or a solution for the problem? – Travis Pflanz Dec 7 '12 at 22:24
  • @TravisPflanz As a cause... Redirection, when incorrectly configured, and generate 404 errors and redirect loops – shea Dec 7 '12 at 22:39
  • 1
    What permalink are you using for the page that doesn't work? can you post a link to the page that doesn't work? If not, just post the permalink that you are using. – Steve Claridge Dec 7 '12 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.