I have a problem with some custom taxonomy terms. I am using "Types" plugin for creating custom post types and custom taxonomies.

I successfully created my postype and hierarchical taxonomy and strated to add content. Everything worked great until I migrated the site from the dev server(Linux) into the live server (Microsoft IIS).

Right now when I add a term as a child to another term in the taxonomy, it gets hidden from the custom taxonomy terms admin panel and I have to type it in the admin search in order to find that term. Also, these child terms don't show up in a hierarchical term navigation list on my site front-end.

I tried:

  • deleting the parent and child term and creating them again. Same thing, as soon as I assign the child term to the parent term, the child term disappears.
  • Clearing cache with w3tc
  • Optimizing DB with WP-DBManager
  • Everything works normally in my outdated development site.

I see a few people seem to have similar issue, but I don't see any clear solution. Some help would be appreciated. Thanks!


1 Answer 1


There's actually an option in Types to hide a post type, and for child posts it may well default to "off." Additionally, you should be able to edit the child post type from the parent type. Or is something actually breaking here?

  • Hi, it's not a feature, there is something breaking. I am having the same problem as described here : wordpress.stackexchange.com/questions/8357/… But I am using the "Types" plugin to created post types and ataxonomies.
    – b0nd
    Dec 6, 2012 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.