I installed a plugin called hide-title by unzipping it and copying the files to the plugins dir. But it doesn't show up in the plugin list.

I've checked the following:

  • the plugin's main php file looks fine at a glance, it has the required header
  • there's no double nesting problem such as "plugins/hide-title/hide-title/..."
  • I've tried chmod -R 777 wp-content
  • The plugin is compatible with my wordpress version
  • I'm not working in a wrong dir - I tried, for example, renaming the twentyten theme to twentyten_ and that got reflected in the dashboard

It seems to be a more general problem because I also tried installing a theme and got the same problem.

I don't want to install the stuff via the dashboard UI because I had FTP/permissions problems with that and gave up on it.


Ok, it turns out that on ubuntu/debian, the wordpress files are in 3 places on the filesystem - /var/lib/wordpress, /srv/www/wp-content and /usr/share/wordpress. I had to do this for all three:

sudo chown -R www-data .
sudo chgrp -R www-data .
sudo find . -type f -exec chmod 644 {} \;
sudo find . -type d -exec chmod 755 {} \;

Works fine now. Even installation through the dashboard works now.

| improve this answer | |
  • Good job for finding a solution. You should mark your answer as correct using the green tick – shea Sep 23 '13 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.