When changing premalinks, none of the pages and links are not working except home page :(

enter image description here

Result are shown below. Thanks in advance.

enter image description here

  • Enable mod_rewrite. You can see by the error message that the server did not send the request to WordPress.
    – fuxia
    Nov 25, 2012 at 21:57
  • @toscho how can I do that ?
    – Muhammed
    Nov 25, 2012 at 22:05
  • Depends on your server and how you have set up the localhost. Look up the server docs.
    – fuxia
    Nov 25, 2012 at 22:13

1 Answer 1


This is really a server question and not specific to WordPress.

Be sure mod_rewrite is enabled in httpd.conf Apache on your version of OS X. (Google that with your version of OS X.) Restart Apache after making changes to httpd.conf.

You may also need to add a blank .htaccess file in the /Users/yourusername/Sites folder so the file has the correct permissions and so WordPress can write to it from the Settings >> Permalinks screen in admin. And to do that, you will need to add the .htaccess file in Terminal, as OS X hides unix "invisible" files - files with a leading . - in the finder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.