1

I am trying to run the wp-cron.php manually by calling it that way:

http://mysite.com/wp-cron.php?doing_wp_cron

Disabling the auto cron function with :

define('DISABLE_WP_CRON', TRUE);

produces the same error.

What could be the issue?

  • The question we have to ask upfront: "Why are you calling it manually?". – kaiser Nov 25 '12 at 16:34
  • Is "invalid secret string" the exact (!) error message? If so, the error isn't caused by WordPress. And what is the parameter "?doing_wp_cron" for? – Ralf912 Nov 25 '12 at 17:40
2

If you're launching wp-cron manually you don't need the "doing_wp_cron" parameter. The fact that you have it and haven't given it a value is very likely to be what's causing your error.

1

Edit wp-config.php and add the secret key. A good spot is right after the Authentication Unique Keys and Salts. Please be sure to update the secret to be your own.

define( 'WP_CRON_CONTROL_SECRET', 'qUhYNCrdHSHOPwPgrdyY19yi0' );

Then you can run

http://example.com/wp-cron.php?doing_wp_cron&qUhYNCrdHSHOPwPgrdyY19yi0

Where the part after the & is the secret key which you created with the define statement in wp-config.php

0

For others with this issue, make sure you don't have a plugin like WP-Cron Control enabled (source)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.