2

I'm getting prompted to enter my FTP information (in this case, SFTP) for installing plugins/themes in Wordpress. Problem is, I keep getting denied with valid SFTP credentials.

I have root access to my server as well. RedHat 6.3, MySQL 5.1, PHP 5.3.3

For troubleshooting sake, all of Wordpress's directories are currently chmod 777

Every time I enter the login credentials that I'm SFTP'ing into the server with, I'm met with the error -

ERROR: There was an error connecting to the server, Please verify the settings are correct.

I've tried regular FTP, SFTP, creating new FTP users, using localhost, using the static address, about everything I could think of.

I've even gone as far as editing wp-config.php to include FTP info like so

/** FTP SETTINGS FOR AUTO-UPDATE */
define('FTP_HOST', 'Tried both static IP and localhost');
define('FTP_USER', 'user');
define('FTP_PASS', 'pass');

I can upload plugins and files manually through Filezilla or another client (using the SFTP credentials it is currently denying), but I'd like the ability to do one-click upgrades and installs.

I wouldn't think there is a firewall issue because Wordpress is installed on a localhost MySQL. Pretty sure I didn't say that right.... but you get the idea. I'm not leaving the box I'm on.

3

What if you try http://wordpress.org/extend/plugins/ssh-sftp-updater-support/ ? If that doesn't work you can do a quick code change to get the logs with which the developer of that plugin can use do more diagnostics.

0

Following up from retomate's answer, SSH SFTP Updater Support worked for me, the plugin adds the additional Connection Type options, I used the following settings: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.