I took over a site that displays the category in the URL three different ways.

For some categories it shows "?category_name=blah". (Not ideal, but I can live with it)

For newly created categories it show the "?cat=####" structure. (I don't want this)

Yet for two categories displayed on the home page, it doesn't even show the word "category". It doesn't even show the category slug...it shows a completely different word. Specifically, the category is "first-column", but the URL shows "sitename.org/latestposts". The page title shows "first-column". The other category is "staff-blog" and the URL shows "staff-blog" as well.



How can I get the new categories to stop show the "?cat=####" format?

I read all the notes about permalinks, and the htaccess file seems to be allowing me to make updates. I can't find any references to changing the category name in the php files. I'm over a week trying to figure this out on and off. The original guys won't respond to my emails, so I'm getting really frustrated. Any help is greatly appreciated!

closed as off-topic by Mark Kaplun, Nathan Johnson, Jacob Peattie, EAMann May 2 '18 at 4:37

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Mark Kaplun, Nathan Johnson, Jacob Peattie, EAMann
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Your question isn't really answerable without a lot more information. I'd need the relevant code, mostly, but that could be pages worth if you can't narrow it down. However, I would guess that the theme is responsible for at least some of this. Look in the theme for code that is generating those several different query strings. I suspect is is doing some non-standard manipulation. "?cat=####" is the default format for permalinks, but default for pretty category permalinks is "category/category-name", so something is amiss. – s_ha_dum Nov 4 '12 at 4:19
  • Thanks for responding. There an archive.php file that controls how each category page looks (adds an image and text) but I don't think it effects the URL. Any suggestions of where I would look in the theme files for where this manipulation might be occurring? – DCLiving Nov 4 '12 at 6:10
  • There are 2 places I'd look: 1. In the admin panel, under settings -> permalinks. That's where the permalink structure is defined. 2. In the .htaccess file. There could be specific rewrites there. This file is usually located in the root of the WP install – Lea Cohen Nov 4 '12 at 6:23
  • Ok. Permalinks is set to sitename.org/sampe-post. If I change it, it reverts back to this setting. Weird. There are no plug ins driving this as far as I can tell. – DCLiving Nov 4 '12 at 7:46
  • The HTAccess file has only this:# BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress – DCLiving Nov 4 '12 at 7:47

Check Settings → Permalinks again, if you select default in common settings, all of the pages including categories will be use ?cat={category_name}. To benefit SEO techniques, the best options are post name and custom structure.

Not the answer you're looking for? Browse other questions tagged or ask your own question.