0

Can someone let me know i am using wp pagenavi wordpress plugin

http://renegadehealth.com/blog/?cat=6708

When i click on the next button at the bottom the following link comes:-

http://renegadehealth.com/blog/blog/index.php?cat=6708&paged=2

an extra "blog/blog/" is being added

  • Whats your permalink structure ? – amit Oct 15 '12 at 12:24
  • Permalink structure is:- /%year%/%monthnum%/%day%/%postname% – Gaurav Malhotra Oct 16 '12 at 4:32
1

Why are you using a category link built with a question mark? If you use the correct permalink which is http://renegadehealth.com/blog/herbs pagination is working fine.

  • For the herbs page i am using a page template for publishing all posts in a category. If i don't use WCS hotfix for displaying category then these does not display. – Gaurav Malhotra Oct 16 '12 at 4:31
  • If your permalink structure is /%year%/%monthnum%/%day%/%postname% your category link should look like renegadehealth.com/blog/category/herbs and should not contain any question marks. Try resaving your permalink structure. – mirage Oct 16 '12 at 5:13
  • If you are on a windows server there are some specific permalink recommendations such as adding a index.php to the permalink: /index.php/%year%/%monthnum%/%day%/%postname%/ codex.wordpress.org/… – mirage Oct 16 '12 at 5:21
  • Actually Mirage, the question mark is there because i am using WCS hotfix. Earlier the categories were not displaying and i had to use this plugin. – Gaurav Malhotra Oct 16 '12 at 6:36
  • for some strange reason renegadehealth.com/blog/blog/index.php?cat=18&paged=2 the above url is having "blog" 2 times instead of:- renegadehealth.com/blog/index.php?cat=18&paged=2 – Gaurav Malhotra Oct 16 '12 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.