I really have no idea how to figure out what exactly is wrong and so I'm seeking help here.

When I try to validate my feed I get the following error message:

    XML parsing error: <unknown>:8:17928: mismatched tag
... d/show_ads.js">/*<![CDATA[*/<p>/*]]>*/</script></div><p>The next day I h ...

The source is the original feed URL, not Feedburner itself, of course. The .js is from Google Adsense that I have implemented in my blog posts recently.

I also get this:

In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.

    line 1, column 485: Self reference doesn't match document location [help]

        ... rel="self" type="application/rss+xml" /><link>http://zoomingjapan.com</l ...

Source here is Feedburner itself.

What I did so far is that I removed Adsense almost completely from my blog. The feed recovered partly. At first no latest posts were shown in the feed at all. Now they're shown again: http://feeds.feedburner.com/ZoomingJapan So, it seems to have to do with Adsense or it's just all a huge coincidence.

However, what I still don't understand is why the usual Feedburner layout isn't showing up, the the typical RSS Feed Layout instead. Something seems to be going wrong there!

Can anybody tell me what exactly is wrong and what I need to do to fix this problem? Let me know if you need any additional information.

Thanks so much in advance.


Well, Feedburner and AdSense don't work well together any more. Google is progressively shutting that down. You can read about it in their official "Spring Cleaning" announcement.

But also, you likely have a major issue with your site in general. This is what I see when I try to visit your blog page:

Error Page

Now that your site is working, I was able to load your raw feed to see what's going on with it. The crux of the issue is that your feed - the XML being served from your site, not Feedburner - is broken. Feedburner then tries to parse this broken data and churns out junk itself. Garbage in, garbage out.

I've copied the raw XML your site is presenting in response to requests to http://zoomingjapan.com/blog/feed/ to a Gist: https://gist.github.com/3880465

The issue is, it's not valid XML ... the document starts out OK:

<?xml version="1.0" encoding="UTF-8"?> 
<rss version="2.0" 
     xmlns:slash="http://purl.org/rss/1.0/modules/slash/" >
        <title>Zooming Japan &#187; Blog</title> 
        <atom:link href="http://zoomingjapan.com/blog/feed/" rel="self" type="application/rss+xml" />
        <lastBuildDate>Wed, 10 Oct 2012 15:03:55 +0000</lastBuildDate> 

But every XML validator I run your feed through complains about the <script> tags littered through your content. In reality, you shouldn't have <script> tags in content to begin with - they belong in the <head> element of your page.

| improve this answer | |
  • Still? I thought we took care of that already: wordpress.stackexchange.com/questions/53630/… .... Any idea what I could do to get rid of that cryptic problem .... jeez :/ Thanks a lot for your answer. Does that mean I can't use a proper working feed anymore as long as I implement Google Adsense? – japanworm Oct 10 '12 at 16:36
  • Sorry, actually it was this one here: wordpress.stackexchange.com/questions/59309/… – japanworm Oct 10 '12 at 16:42
  • I tried everything I could. I can't reproduce the problem you are reporting and thus I can't fix it. Is it somehow possible for your to try and help me despite of that? I edited my question, too. It should be possible to fix the feed somehow without removing Adsense, right? – japanworm Oct 12 '12 at 17:37
  • 1
    see my update... – EAMann Oct 12 '12 at 17:52
  • Thanks so much! I usually never put javascript in my content directly, but I thought for Adsense there's no other option and I also wanted to be able to choose for each blog entry where I put the ad to see what works best. That's why I didn't hardcode it into the single.php. What other options do I have if I want to keep Adsense in my content? – japanworm Oct 12 '12 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.