1

I'm using qtranslate, and whenever selected language translation doesn't exists it outputs text like this: (English) This is english text. So it gives me (language) string inside the output. I'd like to get rid of this.

So that if I select russian language, and text is not translated yet I see english language text but no (English) attached automatically.

Any ideas how to do this? I looked in backend carefully and it doesn't seem to have any settings for this.

I'd do php trim or smth else but there should be easier way to do this...

closed as off-topic by Johannes Pille, Mark Kaplun, birgire, Pieter Goosen, Nicolai Oct 5 '14 at 19:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – Johannes Pille, Mark Kaplun, birgire, Pieter Goosen, Nicolai
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Copy the english translation over other languages. That's how i cope with it. – Zlatev Oct 10 '12 at 12:34
  • @Zlatev I thought about this too, but this is such an ugly solution. I'd prefer to do something programatic. – user8842 Oct 10 '12 at 13:15
  • I'm not sure if it's helpful, but I remember of setting a generic language all to deal with some empty content. That site is no more, and I'm not sure if I found this hint in qTrans forum or at WP.org. – brasofilo Jan 5 '13 at 3:37
1

you should find this options in qtranslate configuration page: "hide not translated content" (or something similar to)

  • That's not helpful. Please provide more details and use Upper-/Lowercase letters. Thanks. – kaiser Oct 10 '12 at 14:08
  • i can't understand what could change by using upper/lowercase letters. Anyway: if you choose that option (i do not know which is the correct label 'cause my wordpress setup is in italian by the way), qtranslate hide contents when they're not present in that specific language – frabiacca Oct 10 '12 at 15:38
  • A) Please update your question with additional info B) It's about writing answers in proper Upper-/lowercase letters. At least this is no chat. – kaiser Oct 10 '12 at 15:50
  • This just removes posts from the loop. I have different requirements. – user8842 Oct 10 '12 at 17:12