I have installed and converted two wordpress installations to Multisite .It was not first time and I done it before for some of my websites.

I was successfully able to use it too.But I could not find sub-site files/folders in 'Blogs.dir' .Hence some plugins are showing errors as there are no files/folders for sub-sites(like subsite 1, 2, 3 etc) in blogs.dir

The problem might be this...I firstly placed the Multisite conversion code at long place in wp-config.php .Later I realise my fault and corrected it.But the problem is still un-resolved.Still there are no files in blogs.dir

Could anybody help me to resolve this issue? I don't understand if it is because of the new version 3.0.4 or my fault ?

Thanks !

Update: I installed a new multisite on other fresh domain .And the same problem there. I think the new version don't need that or some thing wrong with my server configuration

Update 2 : I am adding a screenshot of my empty blogs.dir folder http://img534.imageshack.us/img534/768/blogsdir.jpghttp://img534.imageshack.us/img534/768/blogsdir.jpg

Update 3:

Actually the problem is caused with a plugin named Zingiri

The plugin is installed on Multisite installation and got these messages :

Directory /home/..../public_html/wp-content/blogs.dir/2/files/ is not writable, please chmod to 777 Directory /home/......./public_html/wp-content/blogs.dir/2/files/zingiri-web-shop doesn't exist ......... ......... Directory /home/....../public_html/wp-content/blogs.dir/2/files/zingiri-web-shop/digital-a42fzcxaq5ykww4t doesn't exist Turn off magic quotes on your installation. Read more about why you should disable this setting

( ( 1 )This is the warning message on sub-sites.The Numeral ' 2 ' represents a subsite here )

I am having another error message too (here :/wp-admin/admin.php?page=zingiri-web-shop)...when I click on Install button in plugin settings page (However it finishes installing the script).

Error:Table 'wpuser_wpdb1.wp_2_users' doesn't exist

'Magic Quotes ' are already turned off and tried changing the permissions for blogs.dir .

Even after doing all these,that problem is unresolved .

After realizing the issue is caused with that particular plugin .I attempted to delete the question because some might thing this question is related to plugin and not with blogs.dir


  • Is the blogs.dir folder there at all? If it is what are the permissions on that folder? Jan 11, 2011 at 10:52
  • Sancho, Yes ! The folder is there and the permissions are 755 .I have checked it with 777 too.
    – user391
    Jan 20, 2011 at 7:28

2 Answers 2


The instructions clearly state you must create this folder under the wp-content folder.

This isn't a bug or an issue with your server. You missed a step.

http://codex.wordpress.org/Create_A_Network http://wpebooks.com/2010/09/how-to-enable-multisite-in-wordpress/

  • I already created blogs.dir.The problem is that I could not find the Folders like subsites....1 , 2, 3 etc under blogs.dir
    – user391
    Jan 11, 2011 at 13:05
  • The multisite installation is not newer to me.I had some other Multisite installations and there was no problem .Now the problem is with new installations
    – user391
    Jan 11, 2011 at 13:06
  • I got answer Thanks for your help Andrea ! A plugin caused confusion
    – user391
    Jan 11, 2011 at 14:50

I am closing this post as the problem has been solved .

Update : @MikeSchinkel Sorry !I am updating the details and reason for attempting to delete the question .I also added the reason for deleting the question (update3 in question)

Actually the problem have not solved .I marked it solved and attempted to delete after realizing the problem is with plugin

  • @user391 - I reopened. The purpose of the site is to help many people with the same problem by leveraging the needs of one individual with the problem. Please post your answer so that others can benefit. I'm sure you didn't realize it but "Closing the post" is selfish and results in only benefiting you. Please post the answer so that others can benefit. "Pay it forward" as they say and maybe others will help you in advance too. Jan 11, 2011 at 17:38
  • Sorry ! actually my question is imperfect as the actual problem is caused because of a plugin named 'Zingiri' .Actually the error is with Non-compatibility of the Plugin with multisite.I have attempted to delete the question as it is plugin specific. someone told that I should ask plugin related questions on wordpress forums or directly the plugin developer.
    – user391
    Jan 12, 2011 at 7:43
  • @user391 - even information about incompatibilities can be useful for others. No need to worry that you have not found "the perfect"(tm) solution, it's just about sharing.
    – hakre
    Feb 11, 2011 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.