I installed Ubuntu 10.4 then I installed Bitnami LAMP stack then I installed bitnami wordpress module then I tried to make the site into a multisite by following these instructions:




I can elaborate if needed: I enabled multisite in my wp-config.php file. Then I created a network using the wordpress dashboard. I was given two blocks of text to copy and paste 1 block into my wp-config.php file and one into my .htaccess file. I did that and now I get this:

When I go to my mywebsite.com I get this (this was there before I switched to multisite):

before switch

If I go to mywebsite.com/wordpress I get this (this used to be a functioning wordpress theme):


If I click on "My Blog" it redirects to 1mywebsite.com (where the "1" came from I have no idea)

If I try to login by going to mywebsite.com/wordpress/wp-login I get this:


and if I enter my user and password it redirects me to mywebsite.com/wp-login.php and gives me "Not Found" The requested URL /wp-login.php was not found on this server.

NameVirtualHost *:80
    <VirtualHost *:80>
    DocumentRoot /opt/lampstack-5.3.16-0/apps/wordpress
    ServerName mywebsite.com
    ServerAlias www.mywebsite.com

1 Answer 1


I don't have experience with bitnami so I don't know how it changes the apache configuration but I would say the problem is the domain mapping.

mywebsite.com maps to lets say /var/www/mywebsite but your wordpress is installed in /var/www/mywebsite/wordpress so the url to it isn't mywebsite.com but mywebsite.com/wordpress and when you login it redirects you to mywebsite.com/wp-login beacuse in the dashboard you set the site address as mywebsite.com and not mywebsite.com/wordpress.

I would say you have two options:

You can change the site address that you entered in dashboard throuhg mysql in table wp-options, the siteurl value (you can do that thorugh phpMyAdmin if it is installed on the machine)


Change the document root for mywebiste.com in you Virtual host to the directory where wordpress is installed (you just add /wordpress to the end) (VirtualHost examples if you're begginer with them)

  • My wordpress folder is located in /opt/lampstack-5.3.16-0/apps/wordpress... I am going to try to follow this guide to fix it: lanexa.net/2011/08/…
    – piratepartypumpkin
    Sep 26, 2012 at 19:59
  • Yes that changes the siteurl value in wp-options table
    – Alen
    Sep 26, 2012 at 20:01
  • Well, I tried to follow those instructions from that website and it's telling me that 'mysql' is not installed. But when I run the command ctlscript.sh restart mysql, it does just that, it stops mysql, then starts it. So I'm pretty sure I have mysql installed. Furthermore, I have tried to do this through the wp-config.php file by changing define('WP_SITEURL','http://'.$_SERVER['HTTP_HOST'].'/wordpress'); and define('WP_HOME','http://.$_SERVER['HTTP_HOST'].'/wordpress'); to: define('WP_SITEURL','mywebsite.com'); and define('WP_HOME','mywebsite.com'); to no avail
    – piratepartypumpkin
    Sep 26, 2012 at 20:14
  • I also tried to set define('WP_HOME','mywebsite.com/wordpress'); and define('WP_SITEURL','mywebsite.com/wordpress'); and that didn't work either. So basically, right now I am stuck at mysql not being recognized
    – piratepartypumpkin
    Sep 26, 2012 at 20:17
  • wp-login.php i think redirects to siteurl values from mysql not the wp-config.php but I'm not sure about that. I suggest you put wp-config.php back to original values and try to change the virtual host for mywebsite.com
    – Alen
    Sep 26, 2012 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.