I've uploaded a Wordpress site to the live server and I get this error whenever I try to insert an image into a post:

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.0 (Fedora) Server at www.sitename.com Port 80

Just to be clear - the error appears only when i try to insert the image into the page. I can upload it to Media just fine. Also, it happens with external images as well as local ones. It seems enough to have an IMG tag with something in the SRC attribute for this to happen.

It's very weird, I've installed Wordpress on many servers and never had this happen before.

1 Answer 1


The problem was with ModSecurity settings blocking some of the Wordpress scripts.

  • 2
    Please explain how you fixed it to turn this fragment into an answer.
    – fuxia
    Commented Sep 24, 2012 at 14:51
  • Unfortunatelly I don't know the exact fix - I sent an email to the people responsible for configuring the server and they fixed it. Hopefully my answer above will point people in the right direction at least.
    – Andreyu
    Commented Sep 27, 2012 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.