I have two installations of Wordpress in Network mode.

In one network, when I change a theme of any one of my network websites, one particular network website has it's theme changed to the same theme I set the first one to.

In the other network, a similar thing occurs, in that a particular theme has become stuck, and will not change to a new theme,

Why is this occurring?


Changing the theme of one network website will change the theme of another website. I don't want this interaction happening.

Also, no matter what I do with the 2nd website (the one which inadvertently had its theme switched), I can't get the theme to go back to the one I want - the new theme is stuck there. Changing the theme makes no difference, the imposter theme remains active.


Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/doig/public_html/wp-includes/functions.php on line 2638

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/doig/public_html/wp-includes/functions.php on line 2638

Notice: wp_register_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/doig/public_html/wp-includes/functions.php on line 2758

Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/doig/public_html/wp-includes/functions.php on line 2758

Notice: automatic_feed_links is deprecated since version 3.0! Use add_theme_support( 'automatic-feed-links' ) instead. in /home/doig/public_html/wp-includes/functions.php on line 2638

Notice: Undefined variable: post in /home/doig/public_html/wp-content/themes/vermillon/functions.php on line 70

Notice: Trying to get property of non-object in /home/doig/public_html/wp-content/themes/vermillon/functions.php on line 70

  • Please add debug information to your question to make answers possible. – fuxia Sep 10 '12 at 9:54
  • Do you use persistent object cache? I had similar cascading theme switch because of option collision (one site was reading options of another out of cache). – Rarst Oct 20 '12 at 8:45
  • 2
    What exactly are you asking? Your question seems to go round in circles. Do you want to know how to change the theme manually? (not using WordPress admin) – shea Oct 20 '12 at 8:52
  • 2
    go to network admin => all blogs and click edit for the blog in question. Here go to the last tab "settings" and scroll down to "Template". Enter twentyeleven. And in the next line stylesheet enter twentyeleven too and save the settings. Now you should have the theme twentyeleven enabled. Check if changing themes is working now (maybe a problem with your current theme) – mirage Oct 20 '12 at 11:25
  • @Rarst: I don't have persistent object cache. – Steve Oct 21 '12 at 9:37

Fixing the base

I'm pretty sure that you've actually checked the base yourself and I don't have to ask …

»Have you tried turning it off and on again?«

Anyway, you need to run through the following chart again, just to be sure:


If this doesn't work, leave all plugins activated, try to switch back to »TwentyTen/Eleven/Twelve«.

Poor magic config tricks

The web is full of bad recommendations. If this still doesn't work, please check your wp-config.php file for the following line:

define( 'WP_DEFAULT_THEME', 'some_stupid_idea' );

If you find it: Uncomment it, delete it, shoot it ... whatever, just get rid of it. It's not necessary and kills your fallback/default theme. It's called de-fault for a reason: It's not a fault.

The Theme

As I can see from your debug output, you're using the »Vermillion« Theme SVN Source. From the top of the repo page you can read the following:

This theme hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

This now tells you where all those Notices are coming from. Actually they are triggered, because the called functions/Template Tags have been moved to the deprecated.php file.

Notice: some_template_tag() is deprecated since version version_#!

Sometimes they are followed by some note that tells you what exactly is the replacement:

Use some_other_template_tag() instead.

Sometimes you got a line number that indicates, where you need to replace the template tag - but sometimes not (cross file in for e.g. Notepad++ for the rescue).

The recommendation

Find a theme that »works for me« and is under current development. Do the same with your plugins. If something doesn't work: Drop it off your system. No one will miss it.


Have you checked the template and stylesheet fields in each blog's 'wp_options' table in the MySQL database? It should give you the correct directory to the currently running theme. Does this setting change when you activate a theme in both blog's 'wp_options' table?


Perhaps theme or plugin which are you using that one or more of them support old version wordpress, so you have to upgrade them. Functions which are listed in bug list in you question are deprecated and alternate functions are available on wordpress website.

Hope this helps you. All the best ;)


Parked Domains (NOT "AddOns Domains") caused a similar problem like this: changing into one domain, make changes to the others. And even deleting WP from one deletes from the other too. It may not the solution, but can check whether it is or not.

  • Do you mean, you pointed it to the same install? It's very hard to understand what you're talking about. – kaiser Oct 24 '12 at 20:11
  • Domain I: example1.com Domain II: example2.com You have the WP installed already on the first domain. But the second domain is parked on the first domain. Then if you install new WP on the second domain, then it will overwrite the first one. That's what I tried to say. :) – Mayeenul Islam Oct 25 '12 at 16:24
  • I do use parked domains, but the problem is occurring with subdomain network sites, not domain mapped network sites. – Steve Oct 26 '12 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.