I'm a WordPress novice trying to help a friend (who is even more of a WordPress novice) with his WordPress blog hosted on GoDaddy.

It was working fine until he apparently (he doesn't fully remember) was prompted to upgrade the software.

Now the blog still works for end-users (you can see it here) but whenever you log into the WordPress admin, you get a Page Not Found / "This is somewhat embarrassing, isn’t it?" page. The URL that the browser has been redirected to is: http://brewstersmith.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F

It seems like the upgrade attempt was messed up somehow. Given I don't know what precisely caused this, what steps should I take to start investigating the problem and ideally rolling back the upgrade (or completing it) so that the blog is usable again?

  • 1
    Let us know if either of these answers helped you out -- Thanks! Aug 24 '12 at 0:28
  • @FlashingCursor -- definitely will come back and let you guys know. +1 to both answers so far for the tips. Problem persists even when I rename the theme directory. Removing .htaccess doesn't do it either. Will try re-uploading WordPress files as Jake suggests asap.
    – Ghopper21
    Aug 24 '12 at 1:39
  • 1
    That's exactly what I'd do. The plugins rename would be the one I try after re-uping all the files except wp-content. Aug 24 '12 at 3:22
  • Close voted - see answer (GoDaddy update didn't finish).
    – kaiser
    Sep 13 '12 at 0:53

The first thing to try:

  1. Manually download a fresh copy of Wordpress
  2. Log into the FTP account and upload everything EXCEPT the wp-content folder

It is important that you do NOT copy over the wp-content folder or the wp-config.php files. These are custom to each site.

This will allow you to make sure the upgrade is complete.

If that doesn't work, you should remove the .htaccess file from the site, and see if you can get access back to the admin.

Also... Godaddy is on my short list of hosts that I won't work with on Wordpress sites, but it does generally work with very basic site setups.

  • 2
    +1 on the Godaddy sucks comment. I won't touch a WP setup on Godaddy -- too many years of painful issues. Aug 23 '12 at 3:46

I've seen this happen before -- Jake makes one good suggestion and I've had to do just that to resolve the issue in several cases.

Another potential fix is to temporarily rename your /wp-content/themes folder (to something like themes.bak) and try to navigate directly to /wp-admin -- there is a chance that a customization to the theme is causing an incomplete upgrade / blocking a database upgrade.

If this resolves your issue, change the directory name back to themes and see if the problem persists.

If changing the themes folder name doesn't resolve your issue, the next step would be to rename the /wp-content/plugins folder and then try /wp-admin again. If this fixes your issue, you'll have change your plugins folder name back to plugins, then update and re-enable each plugin.

* Please make sure you have a full backup of your database before starting this process. You can pull one from the godaddy admin panel under the MySQL options.

  • The theme issue makes good sense. That is a great quick first check.
    – Jake
    Aug 23 '12 at 3:36

Although I'm not a big fan of godaddy, it's not necessarily a godaddy problem. Happened to me on sites hosted at godaddy and Bluehost. If you are getting the yoursite.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F error, this worked for me:

  1. Navigate via FTP to your installation. Check to see if the upgrade.php file is there.
  2. If not, download Wordpress 3.4.2 from www.wordpress.org.
  3. Unzip the download and navigate to the wp-admin folder.
  4. Locate the upgrade.php file and FTP it to your installation /wp-admin folder

Somehow the in-app update process download was corrupted and missed the required upgrade.php which the redirect points to after the update. Good luck!


I ran a patch in GoDaddy found in the WP application section of my GoDaddy hosting manager. Turns out when I upgraded a plugin, the upgrade.php file was completely deleted from the WP-Admin folder. I just downloaded a fresh copy of WP 3.4.2. I uploaded ONLY the missing upgrade.php file (I still had the upgrade-functions.php file) in my WP-Admin folder. Tried to login, had me run a two second database upgrade and poof, I am back up and running. Hope this helps anyone that didn't find a solution!


I got the same error message. It appears the upgrade didn't complete itself.

I downloaded the latest version of wordpress and uploaded everything EXCEPT the content folder through my ftp program, as suggested earlier. When I went back into my admin panel I was prompted to upgrade the database, and magic, everything was fixed.

Hope this helps someone else :)


Thanks for the other answers. Turns out GoDaddy had run an upgrade patch for WordPress which never finished. I reran the patch via GoDaddy and that fixed it!

  1. select your wordpress database in phpmyadmin
  2. select table : options
  3. select Search tab and type "db_version" in option_name, and click to GO
  4. change option_value, A lower number (ex: 31533 -> 31532)
  5. go to http://yoursite.com/wp-admin/upgrade.php

I had this problem and wanted to share a potentially easier fix for users. In my case, I imported a new client site from another server and it was on an older version of WP which needed updating.

I imported into Softaculous and performed the upgrade. The result was a problem accessing wp-admin as you describe.

First thing to test. rename themes folder to themes.bak (for me, this didn't do anything)

Second thing was to rename plugins folder to plugins.bak (this worked. Now, i can access wp-admin and perform the database upgrade)

*NOW rename both those folders as they were e.g remove the .bak

This fixed it and allowed me back into wp-admin no problem.


In my case it was the w3 cache plugin that was causing the problem. After renaming the plugins and themes folders adding .bak, when I refreshed the wp-admin page, I got a series of error messages telling me which files to delete. Went back to cpanel to rename the folders to their original names (without the .bak) and deleted all those files. Refreshed the page each time and finally got a message to update the database and THANK GOD it worked! I am back in! Ouf!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.