1

I have my website setup with Wordpress in its own folder. The URL website.com/wordpress is currently a 404 (which makes sense since the page doesn't exist), but I want it to redirect back to the root.

I've tried using the Redirection plugin to setup the redirect, but it is still a 404.

Any ideas?

  • This is actually an .htaccess question, not a WordPress question. – Chip Bennett Aug 21 '12 at 15:56
1

Wait, scratch my comment above. :/

  1. Go to Admin -> Settings -> General
  2. Ensure WordPress URL remains the same (e.g. example.com/wordpress)
  3. Change Site URL to remove the subdirectory (e.g. example.com)
  4. For good measure, go to Admin -> Settings -> Permalinks to flush your rewrite rules

That should be all you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.