I've looked at all the help for changing footers but I still have the same problem - I go to appearance, editor, footer.php, change the telephone number that had been previously entered, hit update, and it goes right back to the old telephone number. I checked the permissions and my login is the "owner" and has full permissions for every file.

I'm also unable to update plugins or wordpress themes/editions with the login I use for Wordpress. And...I can't seem to get pictures to load at all. Maybe those three go together, but if they don't, I'm most frustrated about the footer issue.

I should probably also add that someone else set up the site, and did so under a different computer login. HOWEVER, when I check the details, my login has every single permission the admin does. So I don't think this is the problem. It also says my login is the "owner."

  • 1
    what do you mean by "And...I can't seem to get pictures to load at all. Maybe those three go together, but if they don't, I'm most frustrated about the footer issue." ?
    – vajrasar
    Aug 18, 2012 at 21:56

3 Answers 3


Hmmm sometimes FTP clients will show that you are the owner of the file but it doesn't explain to you that other users don't have read / write permissions. So even if you changed something in the your footer.php another user (WordPress in this case) will not see it.

Did you change permissions or CHMOD your files lately?
If so you might have made you the Owner of everything and blocked WordPress from accessing your photos, footer and that explains why plugin updates don't work.

How to fix
Login to your Server and you need to navigate to your WordPress folder

sudo CHOWN -R www-data:www-data /whateveryourwordpressfolder

This will make Apache (if you use Ubuntu) the owner of The WordPress folder which is what you want.

You'll then want to update Permissions - so that groups and 'others' can read / execute your files

sudo find . -type d -exec chmod 755 {} \;
- this fixes folder permissions

sudo find . -type f -exec chmod 644 {} \; - this fixes file permissions

see also my post http://wordpress.damien.co/2012/04/how-to-fix-your-wordpress-when-read-write-doesnt-work/


This is most likely caused by WoordPress not being able to access your file system.

Add this to your wp--config.php with your FTP information.

define( 'FS_METHOD', 'ftpext' );
define( 'FTP_BASE', '/path/to/wordpress/' );
define( 'FTP_CONTENT_DIR', '/path/to/wordpress/wp-content/' );
define( 'FTP_PLUGIN_DIR ', '/path/to/wordpress/wp-content/plugins/' );;
define( 'FTP_USER', 'username' );
define( 'FTP_PASS', 'password' );
define( 'FTP_HOST', 'ftp.example.org' );
define( 'FTP_SSL', false ); //Set to true if SFTP is enabled on your server

Let me know if this works out for you.


sometimes the theme you use overwrites the normal footer. in this case simply ask the theme owner, or google the theme name + change footer, to find where to change the footer lines. good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.