0

Hi I am trying to create a custom post type display page but for some reason the page is not working and I get sent to the 404.php.Here is my code:

add_action('init' , 'business_manager_register');

function  business_manager_register(){
    //add custom post type
    $args = array(
        'label' => 'Business Managers',
        'singular_label' => 'Business',
        'public' => true,
        'shouw_ui' => true,
        'capability_type' => 'post',
        'hierarchical' => true,
        'has_archive' => true,
        'supports' => array('title','editor','thumbnail'),
        'rewrite' => array('slug' => 'businesses' , 'with_front' => false)
    );

    register_post_type('businesses' , $args);
}

Now in order to display it I have created the file archive-businesses.php.Accoding to the slug I added the link should be something like this:

link/businesses But when I try link to it I get the 404 error same thing happenes for the single-businesses.php.What am I doing wrong here?

2
  • Have you tried - This solution
    – Amit Kosti
    Commented Aug 17, 2012 at 19:32
  • @user985482 How about the rest of the custom type? Are you able to create business manageers and go to those based on the permalink in the edit screen?
    – fdsa
    Commented Aug 18, 2012 at 21:50

1 Answer 1

1

go here /wp-admin/options-permalink.php and save your permalink structure.

if it does not work - check your slugs again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.