0

Hi I am trying to instegrate a slider into my wordpress theme.This is what I have so far:

<?php 
                            $slider_query = new WP_Query(array(
                                        'posts_per_page'=>'5'
                            ));

                            if($slider_query->have_posts()):
                                while($slider_query->have_posts()):
                                    $slider_query->the_post();
                                        if(function_exists('has_post_thumbnail') && has_post_thumbnail()){
                                            the_post_thumbnail();
                                        }
                                 endwhile;
                            endif;
?>

While this does work and retrieves the image I need to be able to retribe the url because I have to set different title attributes that are stored for the caption.

I have also tryed to get the URL using

$url = wp_get_attachment_image_src(the_post_thumbnail());

But for som reason the query returns 10 links img's and I set it to 5 only.Wierd thing is that the even images have no source.

Anyone know of a way to retrieve the thumbnail url other then this? If not then why do I get 10 images in the query?

1

Just change showposts instead of posts_per_page.

| improve this answer | |
  • A code sample and – more important – an explanation could turn this fragment into an answer. ;) – fuxia Aug 16 '12 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.