I cloned a remote site on my local MAMP. I fixed pretty much all isues like permission issues and timthumb cache issue used by my Woothemes Fresh News theme. The only issue now is that the backend is not working properly. I cannot add tags nor pick existing ones. I cannot load the featured image I picked and so on. When I check the access log I see:

[29/Jul/2012:14:59:42 +0700] "GET /wp-admin/load-scripts.php?c=1&load=admin-bar,hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,wp-lists,quicktags,jquery-query,admin-comments,suggest,jquery-ui-mouse,jquery-ui-sortable,postbox,post,media-upload,jquery-ui-datepicker,theme-preview,word-count,editor,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.4.1 HTTP/1.1" 500 -
::1 - -

In the error_log I found

[Sun Jul 29 15:14:47 2012] [error] [client ::1] PHP Fatal error:  Call to undefined function did_action() in /opt/local/www/elc/wp-includes/script-loader.php on line 65, referer: http://elc.local/wp-admin/edit.php

I tried turning off all plugins by renaming the plugins folder as regular deactivation did not work either. But it did not work. Still jQuery / JavaScript issues. I Googled for a solution. No luck. Any ideas to get me back to working on the site locally?

  • I overwrote all wp-admin and wp-includes and now I got rid of these issues. Only the right column in the post-edit.php seems to have been kicked down now
    – rhand
    Commented Jul 29, 2012 at 8:38

1 Answer 1


Had to remove the folders wp-admin and wp-includes and add them again. Now all good. Somehow some of the files did not tag along during the migration. Has been a long time since I had this issue so did not think that would happen. But it did. This was because two different users have uploaded data and data uploaded by one was hidden by another. This happened as I moped a sub domain to another user for security purposes. I will never forget this again.

NB I still have some slides that are not being loaded despite replacing all urls using the tool search-andreplace from https://interconnectit.com/products/search-and-replace-for-wordpress-databases/ by David Coveney. and adding all missing files. But that is another issue I will have to deal with later on.

  • Did you replace both of your folders and it worked? In my case, the file script-loader.php is causing this error. This is my url: www.my-server.com/load-scripts.php?c=0&load=admin-bar,hoverIntent,common,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-ui-droppable,admin-widgets&ver=3.4.2 Commented Nov 26, 2012 at 18:07
  • Yes I did replace both and that worked for me.
    – rhand
    Commented Nov 28, 2012 at 10:04
  • It was a syntax error at my side. I forgot to use url(''); for the background property in my style.css. Commented Nov 28, 2012 at 13:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.