3

I have a SSL certificate and https plugin which both work fine along with changing the Settings in the Wordpress menu to https but I have to manually enter 'https' to see the Secure version, is there a way to make the home page force, or even better become https?

1

Change the site URL to use SSL for the entire site including home page.

  • 2
    Still does not force http – user1370288 Jul 11 '12 at 10:39
  • @user1370288 "still does not force http" Do you want to force http or https? If the above step didn't work, please check your log and please check the .htaccess file of your site to troubleshoot from there. – Pothi Kalimuthu Jul 11 '12 at 13:30
1

You can redirect the visitor to your SSL site using the following code (untested, may need ajusted):

function wpse58098_template_redirect() {
    if ( !is_ssl() ) {
       wp_redirect( 'https://www.mysite.com' );
    }
}
add_action( 'template_redirect', 'wpse58098_template_redirect' );
0

There is a plugin currently I'm using for my one of the wordpress site. WordPress HTTPS (SSL) ( plugin has option to forse SSL for all. )

I personally recommend this plugin because,

Whenever you use ssl for webpages it becomes necessary to load all of its content from secured (Encrypted) servers, Otherwise It'll show a warning of partially encrypted/mixed content error to user.

The problem occurs when you link to external content such as JavaScript or Images, That plugin solve it by storing those external content to your own SSL secured server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.