I was running a Wordpress site using pretty permalinks, and everything was dandy - the .htaccess file was behaving, and url rewriting was working. This weekend, I decided to convert the site into a multisite installation, and followed the instructions with no real problems until I tried to enable pretty permalinks on the new sites. Nothing happened when I saved the changes on the permalinks page - I checked, and the .htaccess file was not changed.

I tried to change the permalinks settings on the original site, but I can't change those settings successfully either. I can enable pretty permalinks with the existing settings (i.e. domain.com/%postname%/), or disable them (i.e. domain.com?p=123), but I can't switch to another type of permalink, only %postname% works. Again, the .htaccess is never updated, but URL rewriting is occurring properly for %postname% pretty permalinks.

I tried deleting the .htaccess to see if WordPress would create a new one, but no, all that did was break the images on my multisite blogs. A new .htaccess was never created.

I thought it was probably a permissions problem, so I tried to change the permissions on .htaccess to 777, but that made no difference. I also chowned .htaccess to apache:apache (for good measure), but again, no dice. The permissions are now identical to those of the file upload folder (which is working perfectly across all sites), but the file is never changed. What confuses me the most is that I never get any kind of error from WordPress about permissions or even being unable to write to the file. I'm turning here in the hopes that someone may shed some light on even a new idea for debugging, let alone a solution to the issue.

Here is my current .htaccess, for reference:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

Thanks in advance,

1 Answer 1


Did you check the Apache capability for it? If Not yet, open the httpd.conf of your Apache directory and remove the '#' that's prepended to the line 'LoadModule rewrite_module modules/mod_rewrite.so' plus change the term 'AllowOverride None' to 'AllowOverride All'. That did the trick for me after a many hours of searching...

  • Yeah, I'd checked that, but thanks for trying. I'm pretty sure that the rewriting is all working as far as Apache is concerned, due to the fact that at least one of the pretty permalinks work preoperly.
    – cjol
    Commented Jul 6, 2012 at 19:51
  • Thx. Where in my WordPress SFTP can I find the Apache directory? Commented Nov 22, 2017 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.