For some reason, the scripts that I have set up on my wordpress install stopped working yesterday afternoon. I had been editing things, but I'm not sure what I could have done that caused it to stop.

Is there any way that I can error check why it's not working, or any common reasons why it might not be?

The site is up at


  • You need to add more information. Is it all JS, or what? – Ryan B Jun 23 '12 at 22:50
  • Welcome to WordPress Stack Exchange. Please take the time to read our How to ask. We cannot figure out which scripts worked before. What does work is your browser update nag – not very useful. ;) – fuxia Jun 24 '12 at 7:35
  • Thanks for the replies guys, and sorry for the vagueness. When I first asked this, I thought that it was all javascript that was not working- after Toscho pointed out that the browser update script was working, I realized that it was just jquery scripts that weren't working- specifically, queryloader2 and MP3 Jplayer. Which leads me to believe that something is wrong with the way I'm calling jquery, but I'm not sure what it could be. – cosm Jun 24 '12 at 16:52
  • My source shows that it's being called with <script type='text/javascript' src='http://www.delsilencio.net/staging/wordpress/wp-includes/js/jquery/jquery.js?ver=1.7.2'></script> – cosm Jun 24 '12 at 16:53

One of your scripts doesn’t use jQuery correctly:

$(document).ready(function () {}

This cannot work because jQuery runs in no conflict mode in WordPress. To make it work change the script to:

jQuery(document).ready(function ($) {}
| improve this answer | |
  • I don't think it's that, because even after changing the loader.js file to jQuery(document).ready(function ($) { it still doesn't work...even removing loader.js and queryloader2.js from the header completely, the third jquery script still doesn't work. (MP3 Jplayer) – cosm Jun 24 '12 at 18:28
  • Changing the way I loaded the queryloader2.js and loader.js scripts fixed those two. I had it loaded with a path, and I changed that using <?php bloginfo('template_directory'); ?>. However, the jplayer script is still not working. I'll keep trying though! – cosm Jun 24 '12 at 19:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.