I've found other posts related to this, but none had a answer to my issue.

After updating to WP 3.4 my visual editor is broken.

Firebug reports this error

Failed to load: http://xxxxxx.com/wp-includes/js/tinymce/langs/pt.js

wp-tin...9-20805 (linha 1)

I've tried setting the theme to a default theme and it WORKS.

So, is there any way I can determine what's causing this in order to fix it?

3 Answers 3


There shouldn't be a pt.js file in that directory. There wasn't in 3.3.2 nor in 3.4. There's several possible issues that could be taking place, but my guess is that your WordPress install has been compromised and your theme files are corrupted. They are then trying to access that js file which is no longer there and it's no longer there because it's within the WordPress core which gets erased during an update.

Download your theme file and do a search for pt.js. Also do a search for eval(base64_decode and see if anything comes up.

  • There's no pt.js at the original theme files nor there's any instance of 'eval(base64_decode' at any of the files.
    – Souljacker
    Commented Jun 15, 2012 at 21:17
  • If the file is only being requested by that one theme, then there has to be a reference to it within the theme files. You search the code of the files for a reference to that file, correct? (Not just searching the theme for that file.)
    – user1337
    Commented Jun 15, 2012 at 22:30
  • I did search within all the files. No reference at all. It might be that it's being referenced through a variable, since it's a lang file (pt stands for Portuguese). I really don't have any clue of what is happening here.
    – Souljacker
    Commented Jun 15, 2012 at 23:03

I've noticed the error recently and came up with a quick fix to it. A simple plugin that basically copies locale files into the includes directory. Very preliminary but has done the trick for me so far.

Load languages from here and copy them into the plugin's langs directory. I've included French (fr_FR.js) by default as this is what I needed, but feel free to use it as you see fit.

Word of advice, though, once this plugin has run, I suggest you disable it as it will continuously check for the existence of those locales for no particular reason; just a little performance tip.

EDIT I am aware this is a less-than-ideal method, but as I mentionned, did the trick for me until the next update, at which point, if the problem returns, I will simply enable and disable the plugin again.


I resolve this problem when I create a blank pt.js file into wp-includes/js/tinymce/langs/pt.js and another one into wp-includes/js/tinymce/themes/advanced/langs/pt.js

  • 2
    -1, Modifying WordPress Core is not right choice.
    – Amit Kosti
    Commented Oct 17, 2012 at 14:39
  • Is not a right choice when the core of Wordpress run as well! I have the same code in two machines and one have this problem and another not. The same code!! This is a Wordpress core bug! It's not a bug of my theme, because this problem happened in all my themes.
    – squiter
    Commented Oct 17, 2012 at 18:10
  • 1
    If the same code is on two machines an one has the problem and the other doesn't, then it sounds like a server config issue. Even if it was a core issue, then a bug should be filed with WordPress. An update to WP will likely erase that change. The core files should never be modified.
    – user1337
    Commented Oct 17, 2012 at 20:13
  • 1
    Editing the core file is never the answer. It just messes up future installations.
    – Nicole
    Commented Oct 17, 2012 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.