1

I'm sold on this one.

A client has reported he can't edit any text on posts or pages on his WordPress site, claiming the visual editor text is white and he can't click on any buttons. Not even the HTML tab works.

He sent me a screenshot where I can see his text is appearing on white (even with red markings from the spellchecker) and TinyMCE buttons are not loaded. He reports the same error using both the latest Firefox and Chrome and not using any browser extensions on Windows 7.

I couldn't reproduce the error on my machine, since the site works fine for me both as an Administrator and as an Editor. Firebug Console also doesn't throw any errors at this point.

I then walked him on the usual steps: clearing browser cache and cookies, logout/login, restart machine, update from 3.3.1 to 3.3.2, update plugins and deactivating them one by one (there's only 2 plugins: Contact Form 7 and the CF7 to DB extension). Installed TinyMCE Advanced. Gave him a fresh user to test. Nothing worked.

I then disabled his visual editor, after which he got a working HTML editor. After re-enabling the visual editor, the problem was back.

At this point, it is clear that the problem is not on the WP installation.

However, as far as WordPress goes (see? not off-topic!), is there anything else I can try to force TinyMCE to work before sending his pc out to die alone in the rain?

  • I wonder if he has anti-virus software installed which is blocking some of TinyMCE's functionality. – user1337 Jun 4 '12 at 21:59
  • First step is to disable your plug-ins. 90% of the time this happens it turns out to be a deprecated plugin causing a jquery conflict. – Jeremy Jared Jun 4 '12 at 23:41
  • @user1337 will investigate into that, good insight – moraleida Jun 5 '12 at 0:22
  • @JeremyJared already did that, but the plugins have nothing to do with it. – moraleida Jun 5 '12 at 0:23
0

Since it works on some machines and not on all, chances are good it's not plugin or theme related. However, be sure to switch to twentyeleven and see if it's working there, as sometimes theme authors will enqueue scripts like jQuery or TinyMCE from Google CDN, which would be disabled if there's something (browser or OS) that's disabling cross-site javascript loading.

Overall best guess: your client has something that is disabling javascript for him.

Solution 1: have your client disable all anti-virus or software-blocking programs (TeaTimer, etc) and check to see if it works again. Make sure Start -> Internet Options -> Security is not set to 'high'.

If that doesn't work, solution 2: have your client install FireBug and using Skype screenshare, LogMeIn, or Remote Desktop go into your client's machine and see what's happening for yourself. Chances are there's a configuration setting that your client's forgotten he set.

If you can't figure it out from there, solution 3: have your client install a new browser - Opera is a great one for this, because very few people have installed it before, giving you a nice fresh start. Test in a vanilla browser install and see what happens.

Good luck!

0

I tried all solutions but none work for me. With clue from @sickhippie I just did something funny and it works for me.

When I connected to the internet using my hotspot for the first time and choose "No don't turn on sharing or connected to device" the wordpress editor and the visual editor will not work.

When I connect and choose "Yes turn on sharing and connect to device" the worpress editor will work.

Right click on the network and click forget network and connect afresh.

Meanwhile this happened to only one of my wordpress website. Other sites work with or without sharing to device option.

Hope this help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.