I want to make some edits to a plugin that I've downloaded. I used the Plugin Editor, but the changes did not show up. I tried refreshing, logging out/back in, and deactivating/activating the plugin.

I gave up on that route and decided to:

  • deactivate/delete the plugin via the admin page
  • delete the plugin folder via FTP to make sure there were no remaining files
  • make the desired edits to my local copy
  • upload the folder to the site via FTP
  • activate plugin

I verified that the new, edited file is up on the server, but the changes still do not show up.

I am guessing there is some sort of caching going on, but I don't know where to begin to clear it.

Other info that may be helpful:

  • The URL of the page that I am trying to update is .../wp-admin/admin.php?page=dlm_addnew
  • The plugin is Download Monitor and the file I updated is uploader.php
  • I have no caching plugins and no wp-content/cache folder
  • My site has cPanel, phpMyAdmin, etc.

Thank you for your time!

  • Does it say You need to make this file writable before you can save your changes. See the Codex for more information. underneath the text area?
    – mor7ifer
    Commented May 22, 2012 at 18:15
  • Actually when I made the edits, it said something along the lines of "File edited successfully". But the changes didn't show up. That is why I decided to just delete the plugin, make the changes locally, and then upload it. Still doesn't work, though.
    – Nathron
    Commented May 22, 2012 at 18:21

1 Answer 1


Easiest way to test for caching - make a plugin-breaking change (remove a ; or something), upload it, and see what happens. If your admin panel whitescreens, congratulations - you don't have caching. If it doesn't, chances are your server is caching all php content with something APC. Contact them and ask about caching.

  • So I tried to break it by removing a semicolon. Didn't work. I contacted my host (hostpapa). They told me to refresh my browser cache (which I tried already). I also tried accessing the page in chrome incognito windows since it doesn't cache pages, and tried shift+f5 and ctrl+f5. My host said that they had no caching on their end.
    – Nathron
    Commented May 22, 2012 at 19:37
  • To confirm for sure, create a file in the root of your site called info.php, and put this in it: <?php phpinfo(); ?>. Then navigate to mysite.com/info.php and search for both APC and cache. If there's still no caching, I wonder if the file you're editing is actually being called/used where you're expecting.
    – SickHippie
    Commented May 22, 2012 at 19:54
  • So I changed directions with this... I searched the entire plugin directory for a keyword of the code I was editing. I'm not sure why, but the plugin has code that isn't even used. I was editing a php file that apparently does nothing at all. haha. What a big waste of time. If anybody has this plugin (Download Monitor), the unused code is wp-content\plugins\download-monitor\uploader.php and the working code is wp-content\plugins\download-monitor\admin\add_new.php. I wonder if this is a bug that happened during an update, or if he meant to have redundant code for some reason.
    – Nathron
    Commented May 22, 2012 at 22:06
  • 1
    It might be there as a fallback for older versions of WordPress. I've run into a couple plugins that have 2-3 versions of a file that are WP version dependent. Glad you got it sorted!
    – SickHippie
    Commented May 22, 2012 at 22:23
  • Thanks for the help! I wasn't aware that developers did that.
    – Nathron
    Commented May 22, 2012 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.