10

I can't access wp-admin at all after changing wp-config folder permission for hardening my security. The content for the site load find, I cant access wp-admin at all, all I get is 404 message.

3
  • have you tried reverting the changes you did to wp-config?
    – moraleida
    May 18, 2012 at 14:16
  • I tried the undo method and Michael way but get "Internal Server Error" :( I did not delete any files or folders
    – John Doe
    May 18, 2012 at 14:39
  • my .htacess file looks like this # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_URI} !^/(wp-admin|wp-admin/.*)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress
    – John Doe
    May 18, 2012 at 14:42

4 Answers 4

12

Delete .htaccess

type in domain.com/wp-login.php

login.

Dashboard -> Settings -> Permalinks -> Save. (just automatically recreates your .htaccess again).

If the problem persists. Try disabling plugins. Enable plugins 1 by 1 until the problem occurs again. That will narrow down the faulty plugin.

1
  • 1
    it turned out i mistakenly change folder permission on wp-admin and wp-includes 3.5 hours wasted.
    – John Doe
    May 18, 2012 at 15:53
0

If ALL you did was to change wp-config.php permissions, look on your folder (or on a fresh WP folder) for wp-config-sample.php, make a copy of it, and fill in the database connection lines again.

Then rename wp-config to wp-config-OLD.php and the copy of wp-config-sample to wp-config.php and you should be fine.

0

Don't delete .htaccess as it may include changes by other plugins like cache creators - at least copy it to .htaccess_bak

It should not be necessary to delete it.

go to yourdomain.com/wp-login.php and login. This should work.

Now rebuild the permalinks: Settings -> Permalinks -> Save

Log out and try again with yourdomain.com/wp-admin

I have to do this every second months, god knows why

1
  • This isn't a 404 error for me, and I can login but as soon as I do it redirects to wp-admin and then it is a 404 again.
    – Eoin
    Jan 17, 2021 at 14:59
0

We had this issue today on a few of our sites & the problem for us was caused by the NGINX caching that we set up on our servers yesterday.

Clearing the NGINX cache resolved this issue for us, hopefully this saves someone else a couple of hours in the future.

Not the answer you're looking for? Browse other questions tagged or ask your own question.