When visiting my site (WordPress 3.0.3), images are loaded correctly. However, when you hit refresh, or come back to the same entry, the images' path become something like this:


Here's the example entry: http://tambnguyen.com/hasselblads-ferrari-branded-h4d-camera-now-available-for-only-a-few-thousands-of-pounds/

Will you please tell me why it's doing that? This string of "ic.cf62525f6780c4cc3784907fe26cbee5.xhassleblad-h4d-40-stainless-steel,j.jpg" is hindering me from sharing the entry's URL correctly on facebook.

I've gone through all the includes files to look for anything with "ic." or "md5" and had no luck. please help.


  • 1
    Maybe something todo with the timthumb script? Easy way to confirm would be to switch theme. – t31os Dec 9 '10 at 17:34
  • 1
    I am unable to replicate this at your example page. Had you tried another browser? With JavaScript disabled? – Rarst Dec 9 '10 at 17:34
  • 1
    Nope, I can't replicate it either. – TheDeadMedic Dec 9 '10 at 17:53
  • This is the screen shot. jpegtown.com/user_uploads/Z9j3ZjE_Untitled.png – aZn137 Dec 9 '10 at 20:07
  • and yes, i've tried this on IE, FF and Chrome. – aZn137 Dec 9 '10 at 20:07

I see what you're talking about. Looks like the images are being generated by the timthumb script and that slug references a cached image identifier. Without seeing the plugin or script thats generating those images, its hard to say how to fix it.

On first view of an image, the image path looks like http://tambnguyen.com/wp-content/themes/13Floor/timthumb.php?src=thumbs/Linus_Lundin.jpg&h=136&w=136&zc=1

and after refreshing, its more like http://tambnguyen.com/wp-content/themes/13Floor/ic.ab271bb704a7768685cd1f6d6cd3eb8f.136x136xtimthumb,ophp?src=thumbs,_Linus_Lundin,j&h=136&w=136&zc=1.jpg

Either way probably doesn't work for facebook sharing.

Why not just include the raw image (ie. not processed through timthumb) in a hidden div in your single.php template? That way you have something to show if you want to share the post on facebook?

| improve this answer | |
  • this is happening for ALL images on my site now, not just timthumb... i'm reinstalling it. thanks for your help! – aZn137 Dec 11 '10 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy