0

This page I am editing in the html editor. I pasted in my list from my text editor. You'll notice that the second last list item is all a link, thats because wordpress has taken it upon itself to wrap the whole thing in an empty tag! Why is it doing this and more importantly, how do I stop it?

FYI here is the relevant ul

<ul class="company-details">
        <li>Target Health & Fitness</li>
        <li>7 Sheffield Road Holmfirth HD9 7BW</li>
        <li>01484 681000</li>           
        <li><a href="mailto:enquiry@target-leisure.com">enquiry@target-leisure.com</a></li>
    </ul>

inside that wordpress has added an anchor, if you inspect it using inspector or firebug.

I've added these filters thinking they'd work but they haven't

remove_filter( 'the_content', 'wpautop' ); 
remove_filter( 'the_excerpt', 'wpautop' );
  • when I looked again at my code, there were the wrong quotes in - those curly ones and an anchor was closed wrongly - <a/>. Always double check the code! – Claire Apr 22 '12 at 13:54
0

I don't remember which one, but there is probably a conflict with tone of your plugins. I had the same issue in the past.

Deactivate all of you plugins, then go through and reactivate them one by one.

  • When I re-enabled the visual editor and then saved my page it seems to sort it. Thanks. – Claire Apr 22 '12 at 13:43
  • Nicola, make sure to go back through all your old questions and give the correct answers upvotes and/or checkmarks. If you do not accept answers on your questions, other users are less likely to assist you. – Travis Pflanz Apr 22 '12 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.