Quite suddenly our company site began throwing a 301 redirect error. I've disabled our most recent plugin additions (old additions) and have looked for any kind of recent code adjustments in the theme that might have contributed to the problem. Nothing obvious.

As a quick fix, I installed Mark Jaquith's Permalink Fix & Disable Canonical Redirects Pack. This has fixed the redirect problem but, whether because of or independent of the plugin, now all internal links fail.

I've checked the root level .htaccess file to see if any changes have been made. It's just your standard rewrite rule set for a subfolder installation.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /new/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /new/index.php [L]
# END WordPress

Is there any other place I ought to be looking for smoking guns? Anyway to scan files for redirect problems?

Thanks for your help!

  • I just tried to switch out themes to Woothemes' Placeholder and noticed that ajax form featured in the admin are also not working. It seems that this is a server issue rather than something resident in my files or settings. Could that be true? – Matt Edminster Apr 12 '12 at 7:54
  • Have you enabled anything on your server, made any changes to the server that might have affected it? – Alex Thomas Apr 12 '12 at 8:28
  • It's very possible. The problem is that our site is on an hosted account managed by the gentleman who constructed our old site. So I'm afraid if the troubleshooting is server side, it may take a while to figure out what the issue is. It may be time to make a break and get our own space. – Matt Edminster Apr 12 '12 at 9:26
  • Do you know who the site is hosted with? – Alex Thomas Apr 12 '12 at 10:19
  • It's with Dreamhost. – Matt Edminster Apr 12 '12 at 13:58

Looks like CloudFlare just went live. Any idea what the cause of the troubles is. It would sure be nice to have some kind of inocculation.

Okay in that case, CloudFlare requires that you use the "Add WWW" option here. However, if your WordPress install isn't told to do the same, they conflict and result in the infinite redirect loop. So, in your WordPress dashboard, go to Settings > General:

Both "WordPress Address (URL)" and "Site Address (URL)" on that page should both have the 'www' manually added there so that it will cooperate when dreamhost forces the same.

Try that

| improve this answer | |
  • This solved it for me! Thanks a million Alex. Is there anything I can do to increase your creds here? – Matt Edminster Apr 14 '12 at 6:13
  • Fantastic, happy to help! Not much you can do on here. Maybe a mention on twitter would help though :). – Alex Thomas Apr 17 '12 at 20:21
  • Oh and i might suggest you have a quiet word in "the gentleman who constructed" your old site and ask him not to make server changes without consulting you first! – Alex Thomas Apr 17 '12 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.