after creating a custom post type with custom post type UI plugin, and after creating the capabilities for a new role to edit, delete and publish it's own custom posts with User Role Editor plugin, i've encountered this issue.

if two or more of the users published content in the custom post type, the system will show a new filter link called "Mine" for each of the users, and it will be the default filter for this page: http://www.mysite.com/wp-admin/edit.php?post_type=custom

the problem is that it echo's "no item found.", although the user clearly have published content in this custom post type.

when i switch to the "all" filter it will show also the user's content, but not in the "mine" filter. it's very frustrating!

can figure it out after several hours. can somebody help with that?

I don't have code actually, it is more of a Plugin / core capabilities misusing, that I don't really understand. the flow was like this (and i'm sorry but the images will be in Hebrew. i tried to translate all of the important stuff that are problem related):

I have created a custom post type with "custom post type UI". Up until now I have never had any problems with this plugin (it's my first multi users / different roles kind of site).

I have created a new role with "User Role Editor" Plugin or with "Members" plugin. the problem below is accruing on both, and that's way i think it's not a plugin bug.

I added to the Subscriber Role this list of capabilities and (message is the name of the custom type), without the capability "edit_others_messages as in

without edit_others_messages

and when i'm using as subscriber, the default url of the "all messages" menu button is the "mine" link, and it's empty! - no messages found!

mine tab - no messages found

but when i'm clicking the "all" tab, it does show me the list of all messages and knows what post is of that subscriber user, and which of them isn't.

enter image description here

so what i want is to understand how to give the user role the permission only to manage it's own custom post types, but to aliminate the "not found" query at the "mine" link (that is - the primary query of the "all messages" page "wp-admin/edit.php?post_type=messages"

please help.

  • 3
    Kindly provide the code that you're using to create the roles, the post types, and anything else that is of relevance.
    – soulseekah
    Mar 23, 2012 at 17:56
  • @Soulseekah, I've added the info, after the horizontal line. if you know something about it, I would appreciate your help. Mar 24, 2012 at 0:24
  • 1
    You should change WP_LANG to en_EN for posting screenshots. Hebrew is hard to read :P
    – kaiser
    Mar 25, 2012 at 23:55
  • didn't thought about that. will do next time. :) Mar 26, 2012 at 6:44

1 Answer 1


I tried to reproduce what you did. My subscriber role has the following capabilities:

  • delete_messages
  • delete_private_messages
  • delete_published_messages
  • edit_message
  • edit_messages
  • edit_private_messages
  • edit_published_message
  • publish_messages
  • read

I marked one of the capabilities "edit_message". I don't see this in your picture. But it was absolutely necessary for me to even post messages. Why does it work for you without it?

Which wordpress version do you have?

Then I created two subscriber users and posted messages as them. The mine filter is working perfectly well for me.

So I'm not able to reproduce your problem.

Either you provide more information how to reproduce the problem or you could make a backup off your site where the error occurs and I would try to debug this locally if you can provide me the backup.

Local Debugging

I have Eclipse and Xampp locally installed. With this I can set breakpoints and step through the code to see what is actually happening. This helps a LOT for debugging.

This article describes how to set up such a development environment: Configure Eclipse PDT with X-Debug and XAMPP.

The links in this article are a little outdated. New versions of the necessary tools can be found here:

Now you need to get a local copy of your code and your database on your local server to debug it.

Code can be simply retrieved via ftp or so. For getting the database I point to another stackexchange answer regarding this topic : Moving database with phpMyAdmin

  • it will be great if you can, but the site itself will be in hebrew (also the admin panel), would this be a problem? Mar 25, 2012 at 21:26
  • i dont know. i would give it a try. maybe google translate helps me XD
    – xaedes
    Mar 25, 2012 at 21:43
  • i'm giving you the rep cause your check gave me another push to check it again in my system. didn't finished yet but i'm gonna find a way myself. thanks! Mar 29, 2012 at 21:53
  • no. still. the issue is that when i did it on a fresh install it worked but on the live site it didn't. i don't wanna mess up the site, so i wont go and disable all the plugins. i did it with the questionable user access plugins only and it changed nothing. what else can i do?!?!? Apr 4, 2012 at 11:42
  • what do you say? what can i do to discover the problem? Apr 4, 2012 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.