2

I have the latest wordpress version installed. When I upload an image in the control panel for a post, I then go to edit it (crop an image for the thumbnail the way I want or rotate or do any kind of editing) and instead it shows a broken image.

The actual images are uploaded, I just can't seem to use the wordpress image editor.

Any ideas why or how to fix? See image below for more detail

enter image description here

2 Answers 2

0

Check the permissions on the file as it sits on the server. Try loading the image URL into a browser and see what error displays. Sometimes I can duplicate the image and reupload and it works. Just some things to try.

2
  • If I right click, open image in new window on the broken image in the screenshot above it will try opening a URL like this... http://www.mysite.com/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=29db12886f&postid=34&rand=94296 and will show a broken image on that page as well. So far everything I have tried has not helped and I have tried uploading several images and all of them have the same result. I change the images full permissions 666 and then 777 but still the same result
    – JasonDavis
    Mar 16, 2012 at 10:45
  • I have made some progress in finding the problem, In my functions file I have about 10 other files that I include into my functions files that do all kinds of stuff, 1 by 1 I disabled each file and eventually I got it working as long as my file I call cd-widgets.php is not included, so my problem is somewhere in my widget code. Shouldn't take long to fix now, thanks for the help
    – JasonDavis
    Mar 16, 2012 at 11:04
0

Had the same problem and find that in one of my plugins I had a file that started with a blank line before

Problem:

1. 
2. <?php
3. /**
4.  * Comment

Solution:

1. <?php
2. /**
3.  * Comment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.