I am trying to update the permalink structure using the back-end and Settings -> Permalinks. The .htaccess file is not updating.

I have given .htaccess full access with chmod -R 777 .htaccess and still, Wordpress says that the permalinks are updating, yet they aren't coming through. When I click, I'm still getting 404s from apache2.

  • 1
    Have you checked to see if .htaccess is actually updating or not? If the rules are being put in, then you may not have mod_rewrite enabled, otherwise you can put the rules in manually.
    – SickHippie
    Mar 12, 2012 at 19:21
  • Looks like I needed to enable the apache2 module rewrite...silly me, basic question. DISREGARD! :) Thanks for the help.
    – dmanexe
    Mar 12, 2012 at 20:04

1 Answer 1


If you have given the correct access and the problem still isn't resolved, but WordPress says that it is indeed modifying the file I think you should double check and make sure the rewrite_module is on. If you're site is live and you're having this problem you need to call your hosting service and they'll be able to help you. However, if you're local, I think I can help you :)

I once had this problem after I started trying out WAMP and I tried everything you stated above. Here's what I did: left click on the tray menu icon, go to Apache > Apache modules, then scroll down and make sure rewrite_module is checked. If it is not, check it. WAMP should then restart and (in theory) your problems should go away!

Good luck! Write back and let us know if it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.