0

I record my problem here.

http://www.screenr.com/pg88

Does someone know what I am doing wrong?

2 Answers 2

2

usually you need to

global $custom_metabox;
$custom_metabox->the_meta();

as described in the alchemy docs. however i can't tell more unless you post your code.

3
  • I solved my problem other way but thx :)
    – Itachi
    Mar 5, 2012 at 15:20
  • i saw that, but i think it defeats the purpose of using alchemy if you are going to fallback to get_post_meta(). i use alchemy all the time and probably could have solved this for you w/ code posted. in my opinion you will get better/more responses if you post code instead of a screencast Mar 5, 2012 at 17:47
  • I usually use get_post_meta but had a problem... tried your way and it fixed my problem instantly. Thanks! Sep 7, 2012 at 10:25
0

Try moving your $metabox->the_value('title') inside your custom loop.

The WPAlchemy object usually tries to get meta information for specific posts, not a bunch at once.

Sorry about the $metabox variable above, I couldn't see what variable you're using.

4
  • So I moved $simple_mb->the_value('title') inside my custom loop and still nothing.
    – Itachi
    Mar 4, 2012 at 16:31
  • Try adding the global $simple_mb; inside the loop as well.
    – Jen
    Mar 4, 2012 at 17:23
  • I did this too. But still nothing
    – Itachi
    Mar 4, 2012 at 18:02
  • Finaly I solved my problem with this piece of code <?php $meta = get_post_meta(get_the_ID(), $custom_metabox->get_the_id(), TRUE); echo $meta['title']?> but with this my problems don't end. I echo my values correctly but they showed only in last post. Here is screen imageshack.us/photo/my-images/825/wpalchemiproblem.jpg Does someone know how to fix it?
    – Itachi
    Mar 4, 2012 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.