1

With wordpress version 3.3.1, shift-enter to insert linebreaks in pages and posts is not working anymore. Has anybody observed this as well? Is there a fix for that?

Thanks!

1

It's working for me -- have you checked your source code on the published post to see if <br> tags are being inserted?

If so, you may want to check your CSS to make sure nothing is over-riding the
tags.

One of the biggest culprits can be float: left being applied to the line breaks.

4
  • No, I don't get any <br> tags in the source. It's just a newline in the html source code itself. – johann Feb 26 '12 at 9:01
  • Clarification: I don't see <br> tags neither in the source code nor in the html editor, but I do see other tags like <h1>. When switching between editor modes, I see the <br> tags for a fraction of a second, so it looks like some javascript/jquery might be removing those tags? At least they don't make it to the database. By the way, the same accounts for manually inserting <br> tags with the html editor - all get removed. – johann Feb 26 '12 at 9:19
  • make sure this isn't in your theme php file anywhere: <?php remove_filter ('the_content', 'wpautop'); ?> -- otherwise it could be your instance of tinyMCE is just not functioning properly... or could be a browser thing.. have you tried in different browsers, or tried a reinstall of WP core? – timshutes Mar 24 '12 at 21:48
  • I'm assuming you've tried this... but just in case - have you tried disabling all plugins and rechecking? – timshutes Apr 16 '12 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.