I have a couple of WordPress websites that are giving me problems with plugin updates. When I check for updates, it appears that there are no updates available, but then when I check the plugins website individually I see that they all have updates available (I have other websites using the same plugins/themes/server and they can update without problems).

I have tried the following to try to resolve it:

  • Completely reinstall the subscription on the plesk server.
  • Reset folder and file permissions. First all to 777 and then seeing that it doesn't work, 755 to folders and 644 to files.
  • Plugin easy updates manager, but it doesn't show the updates either.
  • Deactivate all plugins, but it doesn't find updates either.
  • Updating plugins manually by uploading the new file does work, but it is not practical in the long term.
  • Review logs when checking for updates. No error appears.
  • Delete the update.php file from wp-includes and replace it with one from other websites that does work, but does nothing either.
  • Reinstall the wordpress core.
  • I checked the functions.php file in themes/wp-includes looking for a filter that blocks updates, but it doesn't.
  • I've check for disallow_file_edit and disallow_file_mods defined but cant find them neither (WordPress not showing plugin updates available)
  • Check for _site_transient_update_plugins in wp_options but row is not there (I did not delete it)

One thing I have noticed is that when updating a plugin manually, the translation updates appear but they give an error, download failed: unauthorized, but then when I check the file permissions they are fine...

I have tried everything I have imagined and searched everywhere for information, but I can't find what the problem is. Could anyone tell me or have they had a similar problem?

  • Can you check the wp_options table in the database for a row like '_site_transient_update_plugins` and _timeout ? Is the timeout set far in the future? (You may need to convert the number to a date e.g. an online unix epoch converter) It's safe to delete the rows.
    – Rup
    Commented May 15 at 10:01
  • Is your WordPress cron system running OK?
    – Rup
    Commented May 15 at 10:02
  • @Rup I've check for both rows but they are not in the wp_options table. I've also check logs but no error in wp-cron, just this: 503 POST /xmlrpc.php HTTP/1.0
    – Charlie
    Commented May 15 at 10:58
  • Then that sounds like the update code wp_update_plugins isn't running at all. Apologies, I don't remember off the top of my head how it's triggered, or to go about debugging it. I think it gets run by the cron system, and at first glance it should also be run by opening the plugins page in the admin site.
    – Rup
    Commented May 15 at 11:38
  • I'd probably put error_log() calls into wp_update_plugins in wp-includes/update.php to trace out the flow and work out what's going wrong.
    – Rup
    Commented May 15 at 11:42


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.