0

I have a Serverpilot-managed server that has 2 apps installed on it. One of the apps is my Wordpress website that I haven't touched in a while.

When I'm on the login page, I enter my username/email and password but upon clicking the Log In button, the page just seems to very quickly refresh and do nothing. I've tried the "Lost my password" option as well but entering my username/email there just results in an Error: Please enter a username or email address

I SSHd into my server and here's what I've tried so far:

  1. Renaming the plugins folder to plugins_old and renaming each theme in the themes folder differently and tried logging in and resetting the password. No luck.
  2. Created an admin user in the DB via SQL commands in the wp_users table and the wp_usermeta table (The table prefix isn't the default if that matters) and tried logging in and resetting the password. Same situation as above. No luck.
  3. Installed phpmyadmin, logged into my DB and created an admin user to log in. Didn't work.
  4. Tried using the wp (the wp-cli basically) to create users, list users but the wp command just gets stuck when I run it in my root wordpress folder. I have to Ctrl+C to stop it. I tried using the --skip-plugins and --skip-themes flag too to no avail.
  5. Tried the wp_set_password() method in my theme's function.php but that didn't work.
  6. Tried using the emergency script that is supposed to send you a password reset email but that didn't work either.
  7. I've set define('WP_DEBUG', true) and define('WP_DEBUG_LOG', true) along with WP_HOME and WP_SITEURL in wp-config.php

This is the debug message I get when I try resetting my password (Though I assume a deprecation shouldn't affect me logging in?):

Deprecated: trim(): Passing null to parameter #1 ($string) of type string is deprecated in /srv/users/webportin/apps/andamanguide/public/wp-includes/user.php on line 3070

With all that said, I'd really love to know why this is occurring and why the wp command doesn't seem to be working either.

6
  • If you're running the same version of WP as I am—6.5.2, the current one as I type this—then that deprecation notice is telling you that, for some reason, the $user_login in the retrieve_password() function is null. I'm not sure what would cause that, if you've eliminated all plugins and switched to a default theme like Twenty Twenty Four. Do you have any mu-plugins in place?
    – Pat J
    Commented Apr 26 at 16:28
  • Hey, yes I'm running WP 6.5.2 and I seem to have one file in the mu-plugins folder: 0-worker.php. The plugin name is ManageWP - Worker Loader. Commented Apr 26 at 16:35
  • I can't imagine why that would be blanking $user_login, but you might want to take a look at the code in that file. It's starting to sound like you'll need someone who can take a hands-on look at your system.
    – Pat J
    Commented Apr 26 at 16:56
  • This is the code in that file: codefile.io/f/cP81yWXXtj @PatJ Commented Apr 26 at 17:03
  • 1
    I don't think the ManageWP worker is the culprit here - I use them a lot and this doesn't seem even remotely related. Commented Apr 26 at 20:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.