1

I have tried everything i could think of and searched on the on Internet for the last few days i'm spending ~10 hours per day trying to diagnose this.

the issue:

  1. in WP Site Health i get:

The REST API is one way that WordPress and other applications communicate with the server. For example, the block editor screen relies on the REST API to display and save your posts and pages.

When testing the REST API, an unexpected result was returned:

REST API Endpoint: https://www.mydomain.gr/wp-json/wp/v2/types/post?context=edit REST API Response: (400) Bad Request

  1. When trying to save a file from the plugin editor i get(yes, file permissions are set correctly. even tried 777):

Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

  1. Plugins don't communicate with the server to check for updates.

The Logs: from litespeed error_log there's an entry everytime i try to write a .php file from the file editor or try to check site health which shows:

2024-03-15 09:45:58.850109 [INFO] [2276963] [T0] [23.88.68.54:35334] Status 400: Invalid character in header name: '],"is_nat"'

Tried solutions:

  1. played with litespeed settings.
  2. disabled all plugins/switched to default theme.
  3. checked with the default wp .htaccess
  4. Wrote small php script to communicate with the wc-api and works PERFECT(talk about weirdness???).
  5. re-installed wp v6.4.3.

I can't figure out what could be wrong. do you guys have any idea? thank you in advance

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.